Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got a new computer last week (with motherboard GA-B75M-D3V). On it's motherboard, there is a USB 3.0 port. I tried to use it for transfer a big data to my harddisk by Ubuntu 12.04. But the speed isn't as speed as i use on my laptop (reach 92.2 MBps on my laptop, but on my new computer it is only 21.2 MBps - like ordinary usb transfer). I tried to look on additional driver, but only graphic driver shown there.

Is Ubuntu 12.04 support USB 3.0 natively? If not, Is there any driver for USB 3.0 on my motherboard?

share|improve this question
Linux supports USB 3.0 as of September 2009 (release of the 2.6.31 kernel). Ubuntu 9.10 Karmic Koala was the first version of Ubuntu to support USB 3.0. And no... installing drivers is a Windows mentality ;) Linux supports hardware with generic drivers. – Rinzwind Oct 15 '12 at 14:00
Does it work if you blacklist uas (/etc/modprobe.d/blacklist.conf)? – Rinzwind Oct 15 '12 at 14:01
@Rinzwind How do i blacklist uas on /etc/modprobe.d/blacklist.conf? – lambda23 Oct 16 '12 at 11:56
up vote 2 down vote accepted

Type sudo gedit /etc/modprobe.d/blacklist.conf in a terminal and

then go to the bottom of the file and type in:

blacklist uas
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.