Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

I've Ubuntu 12.04 installed along with windows 7. After trying to update the Geforce driver on Ubuntu (already updated on windows), Ubuntu fails to boot. It will only give me a black screen and ask for log in user name and password and stays on the black screen.

I've tried to fix it from a boot repair disk, which had generated a long report and then told me that Wubi.exe is not found.

How can I retrieve my [revious installation, or fix it please? If not possible what is the best procedure to re install Ubuntu without affecting the partitions please.

Regards,

share|improve this question

marked as duplicate by Jorge Castro, Mitch, Stephen Myall, Anwar Shah, Amith KK Oct 16 '12 at 11:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
When it asks you for username/pwd, does it accept it and boot to terminal? –  Karthik T Oct 15 '12 at 8:51
    
yes, it does. I'll be logged in and can see the documents as well, but can't access them. –  Ibrahim Hammad Oct 15 '12 at 15:30

1 Answer 1

I think there is no problem with booting, sometime updating graphics driver causes this problem.

try ctrl+alt+F1 if you get a terminal screen, then you can try resetting unity

unity --reset

if this doesn't help then try to purge unity and reinstall it.

share|improve this answer
    
Thanks. I've tried to reset the unity and got the following message: WARNING: No display variable set, setting it to: 0 - Process (1768) Gconf-warning **: client failed to connect to the D-Bus Daemon: //bin/dbus-launch terminated abnormally with the following error: Autolaunch error: X11 initialization failed WARNING: Environment incorrect: No D-Bus Daemon running. I also tried to reinstall it but it showed me a message telling that it exists and in final version. Help is highly appreciated please. –  Ibrahim Hammad Oct 15 '12 at 13:01
    
if you are using proprietary driver then try to remove it and install open source driver. check this link help.ubuntu.com/community/BinaryDriverHowto/Nvidia –  Deepak Oct 15 '12 at 15:20
    
Thanks again. Most of the instruction is through the GUI, however, using the jockey command failed for no authority reason. I still appreciate if you can help, noting I'm not familiar with Ubuntu commands, but can follow instructions. Thank you again and hope this issue will be solved. Regards. –  Ibrahim Hammad Oct 15 '12 at 18:51
    
you need root permissions to do that, type sudo su then press enter and then enter your password, you will see # sign instead of $. –  Deepak Oct 15 '12 at 20:19
    
Well Done. Highly appreciated. –  Ibrahim Hammad Oct 16 '12 at 7:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.