Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ctrl-P very frequently to scroll backward in the command history, but I often mistype it as Mod4-P, which is bound to the switch display function.

I've searched around Keyboard shortcuts and CompizConfig, etc., but I couldn't find where Mod4-P is bound. What controls that?

share|improve this question
    
I'm uncertain as to which key is Mod4 - is that the "Super" key? –  Marco Ceppi Jan 5 '11 at 2:19
    
It's the "Win" key. or Super_L in the output of xev. –  Xiè Jìléi Jan 5 '11 at 2:35

5 Answers 5

up vote 3 down vote accepted

Disregard my other answer, it's incorrect.

There are laptops out there that have a physical button for video output switching hardcoded to send Win+p. This is why Ubuntu now interpets Win+p as a video output switching key.

This is hardcoded in gnome-settings-daemon and can be disabled in gconf by setting

/apps/gnome_settings_daemon/plugins/xrandr/active

to false. This workaround probably has a nasty side effect of breaking your real video switch key, if you have one.

P.S. This feature is added via an Ubuntu-specific debian/45_support_new_video_key.patch, but upstream gnome-settings daemon will do the same thing in a different gnome-settings-daemon plugin (media-keys). It is therefore likely that this gconf workaround will stop working in Natty.

P.P.S. There's an open bug claiming that stealing Win+p this way is not nice for people who have sane hardware and want to use it for something else.

share|improve this answer
    
Now I have convinced my self to learn not to press Win-p. –  Xiè Jìléi Jan 6 '11 at 9:50

Install compizconfig-settings-manager, run it, press Advanced Search >, enable the checkbox for searching in setting values, and do a search for <Super>p (and <Mod4>p, just in case -- both spellings appear to work).

On my machine I find that <Super>p is bound by two disabled plugins: ADD Helper and Shelf.

share|improve this answer
    
I've tried but unfortunately they are not found in CCSM. (I have tried to find >p, but only get <Mod4>Print. ) –  Xiè Jìléi Jan 5 '11 at 6:47
    
You're right -- if I plug in a second monitor, <Super>p does something entirely not what CCSM implies it should. –  Marius Gedminas Jan 6 '11 at 8:43

Ubuntu 14.04 simply:

dconf write /org/gnome/settings-daemon/plugins/media-keys/active false

At the command line :)

share|improve this answer
    
Please note that this also disables other media keys such as volume up, volume down, etc. –  Guillaume Papin Dec 1 at 9:06

On Ubuntu Quantal

Find all bindings to Super-p

gconftool-2 -R /apps | grep "<Super>p"
gconftool-2 -R /system | grep "<Super>p"

Unbind them

gconftool-2 -s /apps/compiz-1/plugins/shelf/screen0/options/triggerscreen_key "" --type String
gconftool-2 -s /apps/compiz-1/plugins/addhelper/screen0/options/toggle_key "" --type String
share|improve this answer

For newer versions of Ubuntu, dconf is used (instead of gconf) for changing the gnome-settings-daemon setting: see this question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.