Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My girlfriend has an HP dv6000. In ubuntu 10.10 32bit i use the synaptics on it and all is good but when i disable it and enable it the problem starts. When booting the problem was that the synaptics was not working i then made the changes describe in EDIT 2. Now when i press the disable button in the synaptics touchpad it disables the mouse AND the keyboard. After enabled the Keyboard keys and Mouse clicks do not work. If i click on the panel below, for example the Applications, Places or System buttons the focus gets stuck there forever. I can open nautilus by clicking on it but i can not use the menus, the ALT+F2 function, see the wireless connections, lower the sound through the panel, etc..

Here comes the weird part. If i press CTRL+ALT+F1 (or any other tty for that matter) and then come back to CTRL+ALT+F7 where the gui is everything works perfect again. This started about a week ago but she told me right now. i checked dmesg which is for sometime now throwing some warnings about Skipping EDID probe do to cached edid but for what i could find out this did not create the problem in the start.

NOTE: I do not need to login when i do CTRL+ALT+F1 i just need to change to another tty then come back to F7.

What could be causing this problem?

EDIT 1 - After a couple of tests, this is what happens or is added to /var/log/syslog when i change to CTRL+ALT+F1 after the problem starts:

Jan 4 22:33:07 mary acpid: client 1234[0:0] has disconnected
Jan 4 22:33:07 mary acpid: client connected from 1234[0:0]
Jan 4 22:33:07 mary acpid: 1 client rule loaded

EDIT 2 - I have solved the synaptics when booting up (the problem was that it was not working at all) by adding this to rc.local:

rmmod psmouse
modprobe psmouse proto=imps

EDIT 3 - Found two articles about the same problem: http://ubuntuforums.org/showthread.php?t=1470117 - / - https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/549727/+index?comments=all

EDIT 4 - After some more tests i found maybe the problem (Not 100% sure). When i click on the disable button in the synaptics touchpad it makes a change in the file:
.gconf/desktop/gnome/peripherals/touchpad/%gconf.xml
and it makes FALSE the following line:
<entry name="touchpad_enabled" mtime="1294200522" type="bool" value="false"/>
But when i enable it again it does not change the file. It leaves it FALSE that is why i have to do CTRL+ALT+F1 to activate it somehow.

EDIT 5 - I made a file called touchpad.conf in /etc/modprobe.d with the following line: options psmouse proto=imps To test. It still did not work.

UPDATE: The following HP Models are affected by this problem on Ubuntu 10.10:

  • HP DV6000
  • HP DV6500
  • HP DV9000
  • HP DV9200
share|improve this question
1  
I have had this problem since day one. I'm glad to know I'm not the only one. –  Nathan Osman Jan 5 '11 at 5:19
    
Do the Edits that i made then test which one works. If not do the answer i made below. Let me know if it works for your model but please tell me the model where you are trying. –  Luis Jan 5 '11 at 21:50
    
Updated answer. Had to install Ubuntu 4 times to test. Do the 3 steps and you are good to go. –  Luis Jan 5 '11 at 23:15

1 Answer 1

up vote 4 down vote accepted

THIS MIGHT WORK FOR OTHER LAPTOP MODELS

I have to pad my back on this one. The following will solve this problem to anyone at least with a HP dv6000 or dv6500 laptop. Do the following in the terminal:

This is divided into three parts:

NOTE: Before starting MAKE SURE YOU UPGRADE ALL PACKAGES!

STEP 1 - Solve the mouse not functioning when starting the PC problem

Doing this even if your mouse in the dv6000 or any other variation works correctly will not create any other problems.

Type: sudo nano /etc/rc.local and add above the EXIT 0 the following lines:

rmmod psmouse
modprobe psmouse proto=imps

Save an continue with STEP 2.

STEP 2 - Making sure that when you turn OFF and ON the touchpad it stays ON!

Go to the terminal and type:

sudo gconftool --type bool --set /desktop/gnome/peripherals/touchpad/touchpad_enabled true

This will activate the synaptics and make it work (It will make the value true for gnome-settings-daemon) UNTIL next reboot when the problem will appear again. To solve this, do the following step:

sudo gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/touchpad ""

This in essence will disable any chance for gnome-settings-daemon to change the boolean value.

I can confirm this works on the HP dv6000 and dv6500. Please give thanks if this work to you to post #103 for Ubuntu user quirks

Now for STEP 3.

STEP 3 - The making sure this sucker will work because you want to. Force the fix to stay.

Press ALT+F2 and type gconf-editor (For 12.04 and below)

Go to APP -> GNOME_SETTINGS_DAEMON -> KEYBINDINGS

Look for touchpad

Delete the assign value for touchpad. Leave it empty.

REBOOT the pc

share|improve this answer
2  
I had to change this because i actually did no test on a clean ubuntu. Quick reason that it was my girlfriends PC and well.. you can imagine me with a girl next to me VERY ANGRY about ubuntu not working with the mouse problem. So i had to find a solution ASAP!. Anyway just tested on ubuntu clean. The problem appears from the very beginning of installing Ubuntu. i formatted the PC 4 times to make sure everything was working good. Please remember to upgrade everything before applying this fix. –  Luis Jan 5 '11 at 23:13
    
You rock. Your solution works perfectly. I have an HP dv6000 as well. I've found a shell script that works half the time, but like you said, it often wouldn't work after suspend unless I went into a tty and back again. But this solved it. Awesome work! –  user11853 Mar 5 '11 at 6:56
1  
Updated to include that the HP DV6500 also suffers from the same problem. –  Luis Mar 30 '11 at 1:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.