Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a brand new install of nagios3 on ubuntu 12.04. After I log in to the web interface and click any link I get the error:

Error: Could not read object configuration data!

Here are some things you should check in order to resolve this error:
Verify configuration options using the -v command-line option to check for errors.
Check the Nagios log file for messages relating to startup or status data errors. 

I ran it with the -v option and it reported no errors:

Total Warnings: 0
Total Errors:   0

Things look okay - No serious problems were detected during the pre-flight check

The nagios log and apache error log and debug log all have nothing regarding this. Does anyone know how to turn on logging that will give me some kind of useful error? Or if anyone knows how to fix this specific problem without additional logging, I guess that's okay too.

Thanks!

share|improve this question

2 Answers 2

Error: Could not read object configuration data!

I got this error because Nagios was not running. There were no errors in the Apache or Nagios logfiles.

share|improve this answer
    
Thanks @Stefan it works for me as well :) –  Roopendra Jan 2 at 14:05

I had the same error. In my case it was because I had changed the Apache user away from the default www-data. The problem was solved when I added the new Apache user to the www-data group.

In other words, it was an Apache permissions error in my case. I hope that helps you find your error.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.