Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

so i installed ubuntu 12.04 32bit alongside xp sp2 ... chose the "something else" option and gave ubuntu a whole partition of 48GB .. ext4 type partition .. DID NOT give a swap space the installation was successful .. but i cant boot into ubuntu .. there is no boot menu at startup .. xp runs fine .. cant access the ubuntu drive though ..

How can if fix this ??

p.s- NO INTERNET CONNECTION !

share|improve this question
1  
did you choose mount point as / while allocating ext4? Secondly, check where you are installing grub (Just after allocation, there will be dropdown below the partition graphics asking the same). It should be your hard disk not your usb. –  Web-E Oct 14 '12 at 18:21
    
yeah .. i did choose the mount point as / .. and if i remember correctly, i installed grub in the same partition as my ubuntu .. (the 48gb partition) –  Vivek P. Oct 15 '12 at 4:41
    
no grub should be installed in first partition where mbr resides. If you get internet connection, get a bootable image of boot-repair. This will fix the issue in no time. –  Web-E Oct 15 '12 at 6:35
add comment

1 Answer

Well, it's normally a good idea to give around 2 Gig of swap space, but tha's probably not the problem in this case.

Try holding down Shift when you boot up. Sometimes, the Grub Bootloader won't display unless you hold down Shift while it's loading. There's a setting to fix/change that, but I forget what. If I ever manage to find it, I'll edit it in to this answer.
In the meantime, if that doesn't work, you may need to reinstall the Grub bootloader.

share|improve this answer
    
holding down shift didnt help .. will search how to reinstall grub bootloader –  Vivek P. Oct 15 '12 at 4:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.