Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try and mount a disk to two mount mounts I get the following error:

Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.

How do I prevent this message from displaying?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You cannot mount an NTFS volume in two places. This is by design to avoid FS corruption. You can, however, make a symlink from one location to the other.

Let's say you mount it at /mnt/ntfs1 and want to make a second mount point at /mnt/ntfs2. You can symlink /mnt/ntfs2 to /mnt/ntfs1 as follows:

sudo ln -s /mnt/ntfs1 /mnt/ntfs2

Note the order in which the directories are given. The one where it is successfully mounted is first, and the place where you want to "mount" it is second.

Note that this is imperfect as using cd .. in shells will cause you to work within the wrong copy, but for file management programs, this should work, with one caveat, from here:

NOTE: There is the danger of a file becoming corrupted if more than one person tries to edit it at the same time.

share|improve this answer

A safer way than symbolic links IMHO:

  1. Mount the first mount like you used to do it
  2. Create empty directories where you want the additional mount points to be, and mount to the additional mount points via the --bind option, for example:

    sudo mount --bind /media/windows /home/your_user/windows

share|improve this answer
    
Also a very good idea. –  hexafraction Oct 14 '12 at 13:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.