Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I am new to ssh server but I have successfully been running it on other Ubuntu 12.04 computers.

The latest computer I set up with openssh-server only seems to allow one shared connection between all the clients. I never had this problem before with the other computers and I checked the config files are the same as other computers that allow multiple connections.

Also this openssh server shows a bar at the bottom of all the clients ssh terminal windows displaying the Ubuntu version, time of connection, date, cpu.

I don't have this on other setups and have tried reinstalling openssh-server.

What program or option is causing this?

share|improve this question
add comment

1 Answer

My guess is you've installed byobu.

From the package description:

Description-en: powerful, text based window manager and shell multiplexer
 Byobu is Ubuntu's text-based window manager based on GNU Screen.
 Using Byobu, you can quickly create and move between different windows
 over a single SSH connection or TTY terminal, monitor dozens of important
 statistics about your system, detach and reattach to sessions later
 while your programs continue to run in the background.

All logins to your server get automatically attached to the same byobu session, so it seems that only 1 user is allowed to log in.

You can disable the automatic usage via issuing.

byobu-disable

on the command line. You might have to restart the ssh server, or even reboot for it to take effect.

If it's not byobu, perhaps it's screen or tmux, which do the same.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.