Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just bought a shiny new Canon MG6250 multifunction printer/scanner and connected it via LAN. Installing the printing side of things was a breeze, however, I cannot work out how to set up scanning.

I installed the MG6200 series ScanGear MP driver from Canon's site but when I open GIMP or Simple Scan, they say there is no scanner detected. Using GIMP's 'update scanner list' button to search for the scanner does not find it.

How do I tell Ubuntu, GIMP or Simple Scan to look on the network for the scanner? Is there another utility especially for this?

share|improve this question
Found a few pages via Googling talking about xsane and configuring it. Most of them talk about scanning using a USB connected scanner. I tried a few of the outlined tweeks, but none have worked so far. – Andrew Oct 21 '12 at 4:29
Did you try the command line tool that comes with the ScanGear driver, scangearmp? That found it for me. – Noyo Sep 8 '13 at 10:06
up vote 9 down vote accepted

Just got this going today. This is how I got it working over wireless network, running Xubuntu 12.10 64-bit. (No Canon drivers were needed).

After installing xsane:

  • The sane man pages refer to "backendname" a lot. gives the backend name for the 6250 as "pixma"

  • man sane-pixma (seems to be a man entry for each backend) tells you that network scanners should normally be detected, but if not, add them directly to /etc/sane.d/pixma.conf

  • Edit that file and add a line of the format:


  • IP address can be retrieved from the printer settings, or from the options in the printer itself.

  • After adding an entry for the printer, save pixma.conf

  • Now edit /etc/default/saned and set RUN=yes

  • Then: service saned start

  • Run xsane

Now xsane should discover the scanner, and instead of saying "no devices found" and dying, it should run up (brings up about 4 windows). All the default settings seem to work — just press "Scan".

share|improve this answer
Thankyou for that concise explanation. Works a treat now!! – Andrew Oct 18 '13 at 10:22
Awesome! Glad to help. – Ash Oct 18 '13 at 10:35
Good tip! My scanner isn't on the officially supported list. It didn't respond over the network but worked fine via USB from xsane. – Stephen Niedzielski Apr 14 '15 at 19:46
This is exactly how I resolved an issue with my Ubuntu 15.04, Canon PIXMA MX870 (a network multi-use device connected via WiFi) and Simple Scan. Now everything works very well. Thanks for a great tip! – madjoe Oct 23 '15 at 19:19
Note you have to do sudo service saned start or the service won't actually start. Use sudo service saned status to confirm it has started. You should see: saned is running. – snark Dec 24 '15 at 17:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.