Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last night I installed some applications and updated my Ubuntu 12.04 LTS,since then I encountered a strange right click problem, that is my right click is not working but when I open home folder from launcher right click works again.

Actually problems starts last night when my desktop wallpaper changes suddenly to Ubuntu default, when I tried to change wallpaper I find that my right click is not working.

I tried to reboot system but that also not solved my problem,i clicked here and there but when I opened the home folder my wallpaper changed again to previous one and when I checked the right click it is also working.

Now the problem is that this problem comes back again whenever I turn on my system,and also whenever this problem occurs the Ubuntu desktop menu bar also disappears from unity top panel.

Don't know what is really going on, please can anybody help me.

share|improve this question

closed as too localized by Tom Brossman, Jorge Castro, devav2, Eliah Kagan, Stephen Myall Oct 18 '12 at 23:16

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Any chance you were playing around with CompizConfig Settings Manager (ccsm) just before this happened? If yes, see this similar question for an answer. –  Tom Brossman Oct 14 '12 at 9:36
    
No I don't have CCSM installed, but I think I figure it out, it was probably due to because I had installed cinnamon desktop interface, I removed cinnamon and now my system is working properly. –  KashmirHackers Oct 18 '12 at 9:47

Browse other questions tagged or ask your own question.