Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I force a resolution of 1024x768?

My screen's resolution is 1024x768 and when I installed Ubuntu it was forcefully in 1440x900. I changed it in my account and again I've to change it in another standard account. I don't know any way to change it in login screen. Also when shutting down that black screen with some commands also appears in 1440x900. I don't know why Ubuntu force itself to be in 1440x900. I want 1024x768 in whole way.

I don't know whether it is required but I have Intel chipset 128 MB.

share|improve this question
    
@lambda23 Huh? From this question: I want 1024x768, From the duplicate: How do I force a resolution of 1024x768, with excellent answers explaining how to do it there. What did I miss? I know the causes differ but the question is the same. –  Tom Brossman Oct 14 '12 at 9:55
1  
@TomBrossman Yes, i know the aim is to get 1024x768 (same). But on that case the resolution still can be changed. nepallic want to force it to 1024x968 (higher resolution) from the limit 960x600. (It means nepallic still can change to lower resolution, ex. 800x600) In this case, rainlover have the 1440x900 resolution and can't change the resolution to lower resolution. –  lambda23 Oct 14 '12 at 10:09
    
@lambda23 Hmm, you are correct, sorry about that. It's still a dupe though, but of either this or this. Both of those deal with setting the login screen to a specific resolution. Thanks for pointing this out, I miss things sometimes. –  Tom Brossman Oct 14 '12 at 10:19
    
@TomBrossman It's ok. I know both of them a little like a possible duplicate, but the specific target is different. –  lambda23 Oct 14 '12 at 10:23
1  
What happens when you try this answer? It should change the resolution used for the display manager and for the desktop. It shouldn't matter that the resolution requested is less than the maximum possible. –  John S Gruber Oct 14 '12 at 19:44
show 2 more comments

marked as duplicate by Tom Brossman, Ringtail, Mitch, hexafraction, maythux Oct 15 '12 at 5:14

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

Modern LCD monitors have a thing called "native resolution" - a resolution where a single pixel in the video adapter's memory corresponds to a single triplet of red, green and blue screen elements. Any resolution apart from the native one is approximated using the monitor's hardware, which results in a blurred picture, jagged edges and overall dramatic drop in picture quality, even when switching to the resolution very close to the native one. I suspect that your monitor's native resolution is 1440x900.

Older CRT monitors were much more analogous in this sense and allowed a wide range of resolutions to be displayed with about the same degree of clarity (or blurriness).

Now you can see that the whole non-native resolution support thing is an artifact of the way old CRT monitors worked, and is going to be less and less important (try switching resolution on your Android phone, for example).

If you want to change the resolution to make the fonts bigger, a better option would be to make fonts bigger using Gnome configuration tools.

If you want to proportionally scale the whole desktop, you can look at using xrandr - this at least will give you a nice anti-aliased scaling.

share|improve this answer
add comment

To give you specific answers:

Either the kernel or the X video driver (for most modern machines the kernel) queries your monitor to find out what resolutions it supports, tries to figure out which one is preferred (most of the time the highest resolution the monitor says it will do, for most modern graphics devices using kernel mode switching, this is done in driver/gpu/drm/drm_edid.c). The kernel or X then sets that mode as the default. You see the rest of the modes in the output from xrandr. Most people prefer the highest resolution their device will do.

This EDID communications is a two way transaction over a couple of the wires of most modern video cables, including HDMI. It doesn't work for hookups using only composite video cables, for example.

So the quick answer to your title question is that your monitor says it can do 1440x900 and both the kernel and X tell it to do so. I don't know why Windows chooses a lower resolution mode.

Assuming your xrandr output says you have a mode called "1024x768" you can do the following:

  1. Modify the grub linux line you boot from to add video=1024x768@60. That overrides the kernel's choice. You may also have to delete the "gfxmode" line in grub, or modify it to 1024x768. You should interrupt the boot process at the grub menu and press e to edit the choice you want to use. I got this working on my test system (which sets gfxmode to "text" because I don't use the splash screen). You only need to change this if you really care about the resolution of those shutdown messages.

  2. Add the following to /etc/X11/xorg.conf.d/10-resol.conf:

Section "Screen"  
    Identifier      "Default Screen"  
    SubSection "Display"  
        Modes         "1024x768"  
    EndSubSection  
EndSection

You can use gksudo gedit /etc/X11/xorg.conf.d/10-resol.conf to do this.

That will restricts lightdm and the desktop from start with any but the mode you want. lightdm will start X which respects the mode this file specifies.


Once you have all this working you can add "video=1024x768@60" to the GRUB_CMDLINE_LINUX line in /etc/default/grub. You may need to uncomment and set the GRUB_GFXMODE line to "1024x768" as well. After making changes to /etc/default/grub you need to run sudo update-grub to put them into effect for the next boot.

Again, this isn't needed for lightdm or the desktop, only for the shutdown messages, so you may only want to go through with item 2.

If you are trying to get larger, more readable text there are probably better options available.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.