Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I always get this error when I click on a FTP bookmark in Nautilus:

"DBus error org.freedesktop.DBus.Error.InvalidArgs: Mountpoint Already registered"

When I click a second time it works (not always). This is annoying and makes working with FTP servers no fun. Is there any work-around for this problem?

share|improve this question
2  
Please consider filing a bug report as described at help.ubuntu.com/community/ReportingBugs . –  João Pinto Jan 4 '11 at 22:00
    
I sometimes get this error too but more often in Samba-shares. They are always mounted anyways. Not serious but rather weird. –  con-f-use May 18 '11 at 0:41

2 Answers 2

up vote 2 down vote accepted

I found this ? https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/699840

share|improve this answer
    
On launchpad on the URL you specified, I filed a comment on a workaround for this bug. It's not perfect, but it works. –  Volomike Mar 1 '11 at 18:50

To solve this:

Double click your FTP bookmark, if you have created one. And the error will appear.

Click the "Browse Network" under the active connection that you just tried to connect to.

When you are inside "Browse Network" click on the active connection, that you tried earlier "FTP as xxx".

After this you should be able to connect to the FTP.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.