Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

No matter what changes i make to file associations (actions) in the 'Applications' tab in Firefox, they're totally ignored.
For example, i set .wmv and .avi files to open with 'smplayer' but when i download a file and double-click on it (through the 'Downloads' window), it keeps opening with Totem player.

The default file associations through nautilus ('open with' tab) work fine, i.e. i've set smplayer as the default player and when i double-click a video file it open correctly.

I've tried to delete and recreate mimetypes.rdf but that didn't help.

Any ideas on what else should i check?

share|improve this question
up vote 9 down vote accepted

UPDATE: Ever since Firefox 18, Firefox has GIO support instead of GnomeVFS support, so the workaround below shouldn't be necessary anymore. If anyone's still hitting this issue in recent Firefox versions, this will be unlikely to fix it.

So, take the rest of this post with a grain of salt...

The fix

This fixes it for me:

cd .local/share/applications/
ln -s mimeapps.list defaults.list

and finally, restart Firefox. When it comes up again, its Download Manager should invoke the correct program (as specified in the .list files referenced above).


Firefox (up through trunk nightlies as of this post) currently uses GnomeVFS API to ask "What app should I use to open files with this mimetype?" However, GnomeVFS has become deprecated in favor of GIO.

Nautilus (I'm looking at ver now uses GIO to register user-specified default handler-applications (like smplayer in your case). GIO and GnomeVFS use different files to manage their settings, but the files are apparently in the same format (at least similar enough for the above "ln" hack to work for me. :))

(I've investigated this in a bit more detail on a Mozilla bug report.)

share|improve this answer
After digging a little deeper: I've found that Firefox has optional GIO support added in bug 402892, but it's currently disabled at build-time, by default. If you compile your own Firefox builds, you can enable it with the "--enable-gio" mozconfig build flag. – dholbert Jul 31 '11 at 2:21
In my case, the defaults.list seems to be ok and the mimeapps.list seems to have some 'bad entries'. Nevertheless, your answer helped a lot. Thanks :-) – Pavlos G. Aug 7 '11 at 16:40

To follow up to Peterling's solution, that worked for me. I was messing around with my mime types files forever trying to figure it out. Turns out that installing Nautilus on my Mint17 KDE system was the way to go. It strikes me as ridiculously convoluted that Firefox is looking at Nautilus settings on a system that does not even have it, but there you go. I'm running Firefox 33 BTW.

share|improve this answer

There is nothing to do with firefox.Because the file is already downloaded. if you want to open downloaded .wmv and .avi files with smplayer you can do it like this. right click on any .wmv file and select 'Open With' --> 'Other Application...' and select your favorite application(In this case smplayer) from the list and check the 'Remember this application for "WMV video" files' check box. do the same for .avi files also. alt text

Or if you want to open files from firefox's save dialog box with your desired application just follow this article:

Hope this helps

share|improve this answer
Unfortunately, I've already set the default application through nautilus to 'smplayer' and it works ok there. The problem only happens in firefox. As for the link you gave me, I've already checked it. It's exactly what I'm doing, but it just doesn't work.... – Pavlos G. Jan 4 '11 at 16:49
I've also updated my question so as to be as clear as possible. – Pavlos G. Jan 4 '11 at 16:52

The Applications tab in Firefox preferences controls how to play embedded or linked content, not downloaded files. To change the application that opens a specific mime type via download manager, close Firefox then delete the mimeTypes.rdf file from your profile, then open Firefox again and double click the file in the download manager. It will prompt for the application to be used. Choose /usr/bin/smplayer, then tick the option to remember your choice.

share|improve this answer
I've already said that I've deleted mimeTypes.rdf. Yet, nothing happens. When i double-click on a file, it just opens with Totem... – Pavlos G. Jan 6 '11 at 20:45
Have you closed Firefox before deleting mimeTypes.rdf? – lovinglinux Jan 6 '11 at 21:30

I know this question is now more than one year old but I had now the same problem with Firefox and found the solution after a long fight with a lot of editing and changing.

And I am so happy about it that I want to share it :)

The solution (im my case) is quite simple:

All files that are downloaded with firefox and opened with a click in the download window seemed to be opend by ??? cuz it was not handled with the firefox settings and not with mimeTypes.rdf ... . It is handled by Nautilus. (although I do not know why)

So just start Nautilus ... look for a filetype that is not handled by firefox correctly - right click on it - properties - open with -> choose the application you want this filestype to be opened with ... done.

From now on Firefox will open all files with the wanted app when clicking on it in the download window of firefox.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.