Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use ffmpeg to convert an audiofile with the option

-acodec libfaac -ab 192k 

and use

ffmpeg -i 

on that file afterwards to get the audio file information, it tells me

bitrate: 152 kb/s

Why ist this? Do I miss something here? If I want to convert a file with a bitrate of 192kb it should give me 192 kbit after the conversion, shouldn't it?

Or: How do I get the 192 kbit rate then?

share|improve this question
    
I tried this with on my PC and got similar results. Here's my source file: teeks99.com/examples/audio_check.flac And my result file: teeks99.com/examples/audio_check_out.flac I've got a relatively recent version of ffmpeg (SVN-r26068, built with --enable-libfaac), but a somewhat older version of libfaac0 (1.26-0.1ubuntu2 maverick default). –  teeks99 Jan 13 '11 at 19:26
    
Noone? So this seems to be a bug. Where do I have to report this as bug? (I couldn't find a bugtracker for ffmpeg aac support ...) –  piedro Jan 23 '11 at 9:11

3 Answers 3

up vote 2 down vote accepted

I can't provide any further explanation, but several places (e.g. [1]) mention:

Note that the maximum average bit-rate (what -ab specifies in the context of libfaac) is 152 kbit/s. Setting this higher will be ignored and 152 kbit/s will be used.

share|improve this answer
    
THx for your hint, I wonder how the quality is compared to which mp3 compression. With itunes we always used 192 aac compression. seems a bit low to have 152k only ... but thanks for your answer! –  piedro Aug 19 '11 at 13:33

There are now much better aac encoders for Linux such as NeroAacEnc or fdkaac but if you are still keen on using faac there is a patch that means faac can encode with a bitrate of 192k, and a great deal higher as well. Handbrake use this patch and it can be downloaded from their site:

http://trac.handbrake.fr/export/3222/trunk/contrib/faac/A00-bitrates.patch

Patch Faac and then compile FFmpeg with --enable-libfaac and you can have high bitrate aac files with Faac. Here is a sample encode with the patched faac, encoding directly with faac:

andrew@skamandros~/media$ faac -b 192 -o test.m4a test.wav 
Freeware Advanced Audio Coder
FAAC 1.28

Average bitrate: 192 kbps
Quantization quality: 100
Bandwidth: 20872 Hz
Object type: Low Complexity(MPEG-4) + M/S
Container format: MPEG-4 File Format (MP4)
Encoding test.wav to test.m4a
   frame          | bitrate | elapsed/estim | play/CPU | ETA
11720/11720 (100%)|  192.0  |   21.7/21.7   |   12.52x | 0.0  

andrew@skamandros~/media$ 

And it works as well with FFmpeg. But there are definitely better aac encoders out now...

share|improve this answer

For high and low bitrates you have to specify a different cutoff frequency. without cutoff frequency this example results in a max bitrate of 166kbit/s (+ 2kbit/s muxing overhead):

ffmpeg.exe -y -i input.ts -vn -c:a libfaac -ar 48k -b:a 210k out.mp4

size=     308kB time=00:00:15.01 bitrate= 168.0kbits/s

When I specify the cutoff frequency to half of the samplerate, I can go up to 210kbit/s

ffmpeg.exe -y -i input.ts -vn -c:a libfaac -ar 48k -b:a 210k -cutoff 24k out.mp4

size=     388kB time=00:00:15.01 bitrate= 211.7kbits/s

Likewise, the default will not go below 64.5kbit/s:

ffmpeg.exe -y -i input.ts -vn -c:a libfaac -ar 48k -b:a 20k out.mp4

size=     122kB time=00:00:15.01 bitrate=  66.4kbits/s

But if I set the cutoff frequency very low, I can get 20kbit/s:

ffmpeg.exe -y -i input.ts -vn -c:a libfaac -ar 48k -b:a 20k -cutoff 1k out.mp4

size=      40kB time=00:00:15.01 bitrate=  21.9kbits/s

In these examples I used a samplerate of 48kHz. When using a lower samplerate, the bitrate will/can also be lower.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.