Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I noticed that the volume control when I use xubuntu is not really working properly.

I can see, that xubuntu is recognizing that it should do something and displays a small image indicating volume up/down or mute. But, it is not affecting the sound I hear for instance while using youtube.

When I open my PulseAudio I see in Output Devices Tab two devices: Built in Audio Digital Stereo and Built-in Analog Stereo. The indication for sound volume for the first device actually does react when I press the media keys for volume up/down. But this should be the second device that should be controlled by my media keys. So the question is, how do I change the device controlled by media keys?

Also, I noticed, that under Ubuntu the media keys work fine, and it is possible to control volume with them..

share|improve this question
    
Turn off the Output you don't want. –  Uri Herrera Oct 13 '12 at 22:38
    
Yes, how do I do that though? –  Aja Oct 14 '12 at 15:42
add comment

1 Answer 1

I had the same trouble. The advice on this page fixed it for me:

http://ulno.net/2011/04/16/mixer-control-with-multimedia-keys-und-multiple-soundcards-in-xfce4-on-debian-or-ubuntu/

In short: Settings -> Settings Editor Find the section xfce4-mixer. Set the value of property active-card to the same as the value of sound-card.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.