Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For the last few days, my vlc player is not responding at all, when i try to double click any file or even run vlc without any file, it just doesn't open up.

I tried to open it through terminal and it was working fine but there were no option coming on vlc screen and also if i close the terminal, vlc closes automatically. I can't figure how to make vlc back to its original way so that i can access any file through vlc. Any help will be appreciated..

share|improve this question

3 Answers 3

You can reset your vlc settings by renaming your current vlc configuration folder.
Execute the following command in a terminal:

mv ~/.config/vlc ~/.config/vlc.old

If vlc still does not open correctly you can try reinstalling vlc:

sudo apt-get remove --purge vlc
sudo apt-get install vlc

Before running vlc, make sure it is not still running:

ps ax | grep vlc

This should not return anything. If it does execute the commands below until the ps command keeps quiet (does not return anything any more). Start with the first, then use the next until it gets killed successfully:

  1. pkill vlc
  2. killall vlc
  3. killall -9 vlc

Notes:

  • you can probably delete your old conf folder with rm -rf ~/.config/vlc.old.
share|improve this answer
    
i am not able to kill running vlc....Is there any way to force kill it through terminal?? –  vivek Oct 13 '12 at 17:48
    
I updated the answer to add the kill commands. Make sure to use the correct pid of the running vlc process. –  rosch Oct 13 '12 at 18:01
    
Thank dude.... u saved me...actually kill command was not able to stop the process.....i have to use the system monitor....and then after installing it worked....u made my day....cheers... –  vivek Oct 13 '12 at 18:02
    
I replaced the kill commands with killall which only needs the process name (vlc). The last one should generally kill it. If this helped you might want to accept the answer, thanks :-). –  rosch Oct 13 '12 at 18:15

I recently had a similar issue with my VLC and I found a more elegant solution to this problem and thought I should share it here. You can simply reset VLC settings by typing the following in the terminal

vlc --reset-config

Hope this helps.

share|improve this answer

muyisco answer worked for me, it is also on https://wiki.videolan.org

"i GNU/Linux Delete the ~/.config/vlc and ~/.cache/vlc folders or execute vlc --reset-config in a terminal.

Old versions of VLC had the data stored in ~/.vlc"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.