Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing xampp, somehow localhost bugged on me.

I put my files, changed permissions, in the end deleted the xampp, but I always get this message:

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.

Wiped the folder, tried restarting either, there's no xampp but I'm still getting it, what's the problem?

share|improve this question
    
Did you clean up your browser browsing settings and cookies , offline ? –  user84277 Oct 13 '12 at 13:11
    
did it just now, didn't help –  RnD Oct 13 '12 at 13:16
    
in synaptic , you can delete all part of apache –  user84277 Oct 13 '12 at 13:42
add comment

1 Answer 1

You probably installed a webserver using the Software Centre. Therefore, even if XAMPP is removed, the webserver in Ubuntu still exists and is running.

To figure out which webserver is running (could be Apache2 or Lighttpd or something else), run

sudo lsof -i

It should output something like (this is shortened view):

COMMAND    PID   USER   FD   TYPE  DEVICE SIZE/OFF NODE NAME
avahi-dae  923  avahi   13u  IPv4    9262      0t0  UDP *:mdns 
avahi-dae  923  avahi   14u  IPv6    9263      0t0  UDP *:mdns 
..............................................................

What you are interested in, is the ro that has *:www under the NAME column.

Once you find the line, then see what it says in the COMMAND column. You can then remove the package using the Software Centre.

share|improve this answer
    
It says: gksudo: option requires an argument -- 'i' –  RnD Oct 13 '12 at 13:12
    
@RnD Try using sudo instead of gksudo. This isn't a graphical program so there shouldn't be trouble. To user4124, you may want to grep that with sudo lsof -i|grep "www". –  hexafraction Oct 13 '12 at 15:58
    
Thanks, I replaced gksudo to sudo. gksudo is weird and barfs on the parameters. For the pedantic, the correct was gksudo -- lsof -i –  user4124 Oct 16 '12 at 20:13
    
I just updated the command so that you can now run lsof. –  user4124 Oct 16 '12 at 20:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.