Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 12.04 on my PC months ago alongside windows xp. Both are on separate drives. The PC loads ubuntu as default however recently it stopped recognising it as the default and now loads xp. I haven't changed any settings. If I unplug the drive with xp on, ubuntu loads up fine. I do need the xp from time to time for some of my work but I use Ubuntu the rest of the time as it's superior. The question is, how do I fix it so that ubuntu is default again. There doesn't seem to be any way within xp, not that I can find anyway. Regards

share|improve this question
add comment

1 Answer

This is a BIOS settings problem. Boot into BIOS configuration page and change the order of the boot devices. Set the device (HDD) with Ubuntu first in boot order and your problem will be solved.

Another way (if you don't want or don't know to interfere with BIOS) is to run the boot-repair program. Look here for a How To

Good Luck

share|improve this answer
    
Ok, it is a bios issue. I changed the order of devices and it booted to ubuntu but the BIOS reset itself. I changedthe battery on the m / board but still happening. I'm out of ideas. Please help again. –  Rozza Oct 28 '12 at 15:36
    
How it reset itself ? You have to save the configuration before exit the BIOS page, I think is F10 in some laptops. –  NikTh Oct 28 '12 at 16:13
    
Yes, I followed instructions to SAVE and exit but there you go. –  Rozza Oct 28 '12 at 19:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.