Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have set the rules in ufw for Transmission but when I try to use it it will not transfer and it also says the port is closed when checked under preferences.

If I turn the UFW firewall off it still says that the port is closed but it transfers fine. I then can turn the UFW back on and it continues to work. I have tried setting up port forwarding in my router (Asus rtn12 using DD-WRT 17990) but that has no effect on the closed port message or transferring.

Is there a specific port that should be opened in UFW to allow the transfers or am I just missing something?

I'm a linux nube so please explain any answers a little more thoroughly than normal. Thanks in advance.

share|improve this question

2 Answers 2

Add a rule using the gufw (the UFW GUI) program to allow the port that's set in Transmission. Actually, gufw has a handy preset for Transmission.

share|improve this answer

you will need to enable UPnP in your router ... then using the default incoming/deny outgoing/allow settings for Gufw (reboot if enabled for 1st time), open preferences and select Listening Report and Show notifications. select add rule / Simple Tab / Allow in TCP and port selected in Torrent client / do the same add rule and port for UDP

when you have set these you should see your port in RED in Listening Report

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.