Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Ubuntu 10.04 with my Samsung SyncMaster B2030, native resolution (1600X900) is not found in the list of resolutions.

share|improve this question
1  
In addition to using a short-term solution, consider filing a bug so that the resolution can be correctly configured by default in future Ubuntu releases: $ ubuntu-bug xserver-xorg –  ændrük Jan 11 '11 at 7:18
    
thanks for the pointer ændrük, filed the bug report, bugs.launchpad.net/ubuntu/+source/xorg/+bug/701772 –  Riyaz Mohammed Ibrahim Jan 12 '11 at 3:25

2 Answers 2

up vote 19 down vote accepted

Native resolution for Samsung SyncMaster B2030 is 1600 * 600 60 Hz

  1. Generate the modeline using cvt:

    cvt 1600 900 60
    

    which will be:

    # 1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz
    Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
    
  2. Get the name of the output to which your display is connected:

    xrandr
    

    This outputs among other things:

    Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192
    VGA1 connected 1600x900+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
    

    In this example the name of the output is VGA1.

  3. Create the new modeline (with the values from the output of cvt):

    xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
    

    Note:

    • the above should be in a single line
    • make note of x in 1600 x 900_60.00
  4. Add the above created modeline:

    xrandr --addmode VGA1 1600x900_60.00
    
  5. If everything went well xrandr will list your newly added resolution.

  6. Test the newly added resolution:

    xrandr --output VGA1 --mode 1600x900_60.00
    

The resolution you set with the above commands will not persist across sessions. Until Ubuntu 11.04 you can add the following lines at the beginning of your /etc/gdm/Init/Default to set the resolution automatically every time you log in:

xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode VGA1 1600x900_60.00
xrandr --output VGA1 --mode 1600x900_60.00

This question describes other ways to make xrandr customizations permanent.

share|improve this answer
    
Could you explain the other options in step 3? 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync what do the values mean, so that I could translate that to my use –  Jiew Meng Sep 27 '11 at 6:22
    
But what if the xrandr does not recognize any output name, specifically, not DVI-0, as described in this question: askubuntu.com/questions/186288/… –  ysap Sep 10 '12 at 20:07
    
I did this for my Viewsonic G790 (1600x1280_76.00 native resolution) and got an error: xrandr --newmode "1600x1280_76.00" 223.00 1600 1728 1896 2192 1280 1283 1290 1339 -hsync +vsync xrandr: Failed to get size of gamma for output default X Error of failed request: BadName (named color or font does not exist) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 16 (RRCreateMode) Serial number of failed request: 19 Current serial number in output stream: 19 –  Scooter Oct 27 at 3:58

First type in xrandr in your terminal and see which is the connected device. It maybe VGA1 as it is in this case. If not then replace VGA1 by your connected device in the commands below. Then create a new document and name it eg:- "yourname.sh" Type in:

xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
xrandr --addmode VGA1 1600x900_60.00
xrandr --output VGA1 --mode 1600x900_60.00
unity --replace

and save it in your home folder (this is for resolution 1600x900). Make it executable by:

chmod a+x ~/yourname.sh

open startup applications and click "ADD". Give a name and type in the command line

bash /home/yourname/yourname.sh

click save. The change appears after you log out and log in

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.