Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know that it is possible to run Sim City 4 Deluxe, as this page clearly proves so.

http://appdb.winehq.org/objectManager.php?sClass=version&iId=10515

I have tried two different commands, and the paths are all right, but when I enter them, I simply get a blank terminal line.

WINEDEUB=-all wine C:\\Program\ Files\ \(x86\)\\Maxis\\SimCity\ 4\ Deluxe\\Apps\\SimCity\ 4.exe -d:software -intro:off -CPUCount:1

env WINEPREFIX="/home/jacob/.wine" wine "C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe" -intro:off -CPUCount:1

So, what could be the problem? I'm fairly new, so I'm not really sure what info I need to provide.

Thanks.

share|improve this question
    
Did you install the Wine program on your computer? –  matt davis Oct 13 '12 at 15:18
    
Yes, I have. I run Steam and off of that Black Mesa and Portal without a problem. –  Jacob Larson Oct 13 '12 at 21:04

1 Answer 1

You can install a package called PlayOnLinux. It is an additional front end for Wine. It comes preloaded with a large assortment of installation scripts that Wine can use. Sim City 4 Deluxe Edition is one of the titles they cover. I can also verify that it works as I have used it for Sim City 4 myself.

share|improve this answer
    
Thank you for that! I will definitely be using that in the future. However, I run into one problem when installing. When it asks for the 2nd disk during the actual installation, I go to POL and click "Next", but when I click "Ok" to try and continue the installation, nothing happens. I have tried it twice, and the same results. Any idea? –  Jacob Larson Oct 13 '12 at 5:15
    
I don't recall there being an issue for me like that. I Googled around and it does appear to have been a problem for some people. When it prompts for second disk, maybe place the disk in the drive and don't click on the menus. Wait to see if it will recognize disc 2 and continue on its own. Beyond that many people have some crazy solutions involving copying the discs to the hard drive. I could provide links if you are interested? –  matt davis Oct 13 '12 at 6:04
    
Okay, so, I couldn't get back to the part where is asks for disk two during installation because it never reaches that point; it's just constantly "installing". I also realized that I was using SM4, instead of SM4 Deluxe. Deluxe, however, crashed when the actual installation came up. While POL said the installation crashed, I could still continue through the steps of game installer, but eventually the that crashed too. POL displayed the crash instead of displaying the "Next" to continue the installation anyway. –  Jacob Larson Oct 13 '12 at 6:55
    
Installing SC4 with POL now to see if it gives me any guff. –  matt davis Oct 13 '12 at 13:29
    
The POL install worked for me but it crashed instantly on running. So I tried to do a regular old Wine install and it worked for me. I also ran the first two tutorials which went without issue, except for some musical skips. –  matt davis Oct 13 '12 at 14:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.