Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a VPS hosted 1500 km away. It originally came with 9.10 - and this morning I decided that I really should get to an LTS release, and figured I'd jump to 12.04.

Researching, I discovered that there is no direct path between 9.10 and 12.04, but that I could upgrade via 10.04. After backing up my data, I dove in. The upgrade to 10.04 was successful, and I proceeded to upgrade to 12.04.

Things started to go wrong.

First, I got an error with GLIBC - I retried and got the same error. That's when I stopped the upgrade. I then tried another round of apt-get update && apt-get upgrade and got a list of "unmet dependencies":

  apt: Depends: ubuntu-keyring but it is not going to be installed
       Depends: libc6 (>= 2.15) but 2.11.1-0ubuntu7.11 is to be installed
       Depends: libstdc++6 (>= 4.6) but 4.4.3-4ubuntu5.1 is to be installed
       PreDepends: dpkg (>= 1.15.7.2) but 1.15.5.6ubuntu4.6 is to be installed
  apt-utils: Depends: libapt-pkg-libc6.10-6-4.8
  libapt-inst1.4: Depends: libc6 (>= 2.14) but 2.11.1-0ubuntu7.11 is to be installed
  libapt-pkg4.12: Depends: libc6 (>= 2.15) but 2.11.1-0ubuntu7.11 is to be installed
                  Depends: libstdc++6 (>= 4.6) but 4.4.3-4ubuntu5.1 is to be installed
  libc6: Depends: libc-bin (= 2.11.1-0ubuntu7.11) but 2.15-0ubuntu10.2 is to be installed
  libept0: Depends: libapt-pkg-libc6.10-6-4.8
  libnih-dbus1: Depends: libnih1 (= 1.0.3-4ubuntu9) but 1.0.1-1 is to be installed

I tried to see if I could do something about these - using apt-get -f install. This told me that I would need to upgrade my kernel. I found instructions on how to do this, but when I ran apt-get to install the new linux headers, I got the same dependency errors.

I found another answer here where someone else had had an interruption in their upgrade - and tried the solution that worked for them: sudo apt-get -f dist-upgrade

This resulted in the error:

E: Could not perform immediate configuration on 'python2.7-minimal'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

I tried to resolve this by:

apt-get install -o APT::Immediate-Configure=false -f apt python-minimal

But this simply ended up with this last list of dependency errors:

apt: Depends: ubuntu-keyring but it is not going to be installed
       Depends: libc6 (>= 2.15) but 2.11.1-0ubuntu7.11 is to be installed
       Depends: libstdc++6 (>= 4.6) but 4.4.3-4ubuntu5.1 is to be installed
       PreDepends: dpkg (>= 1.15.7.2) but 1.15.5.6ubuntu4.6 is to be installed
  apt-utils: Depends: libapt-pkg-libc6.10-6-4.8
  libapt-inst1.4: Depends: libc6 (>= 2.14) but 2.11.1-0ubuntu7.11 is to be installed
  libapt-pkg4.12: Depends: libc6 (>= 2.15) but 2.11.1-0ubuntu7.11 is to be installed
                  Depends: libstdc++6 (>= 4.6) but 4.4.3-4ubuntu5.1 is to be installed
  libc6: Depends: libc-bin (= 2.11.1-0ubuntu7.11) but 2.15-0ubuntu10.2 is to be installed
  libept0: Depends: libapt-pkg-libc6.10-6-4.8
  libnih-dbus1: Depends: libnih1 (= 1.0.3-4ubuntu9) but 1.0.1-1 is to be installed
  python: Depends: python-minimal (= 2.6.5-0ubuntu1) but 2.7.3-0ubuntu2 is to be installed
  python-apt: Depends: libapt-pkg-libc6.10-6-4.8
  python-minimal: Depends: python2.7-minimal (>= 2.7.3) but it is not going to be installed
                  Breaks: python-support (< 1.0.10ubuntu2) but 1.0.4ubuntu1 is to be installed
  synaptic: Depends: libapt-pkg-libc6.10-6-4.8

Any ideas on how to dig out of this hole?

share|improve this question
    
As it turns out, I didn't quite read the small print on the VPS. This one uses a shared kernel - so upgrading wouldn't work since the kernel couldn't keep up, hence the dependency problems. Luckily, it is a quick and easy thing to restore to the original installation and I have backups. –  HorusKol Oct 16 '12 at 0:13
    
I am not clear it uses a shared kernel does that mean other users are also using the same kernel? Or there are other sys admins on your server –  Registered User Jan 16 '13 at 19:34
    
It's a VPS on shared hardware... the way that the VPS is setup is such that the kernel is shared across all VPS on that hardware host - not very compartmentalised, really –  HorusKol Jan 17 '13 at 1:12
    
Is there any software available in Ubuntu which can make my laptop or a small spare computer I have work as a VPS –  Registered User Jan 17 '13 at 5:12
    
Short answer: no, not really in Ubuntu. Middle answer: there are various virtualisation systems available, with different strengths and weaknesses. Long answer: serverfault.com/questions/ask –  HorusKol Jan 17 '13 at 5:23

1 Answer 1

I also had the python-problem and then lots of unmet dependencies. At last, after finding out that the real problem is in apt, I just did:

cd /var/cache/apt/archives
dpkg -i apt_0.8.16~exp12ubuntu10.16_amd64.deb

The following apt-get -f install installed all packages, that didn't work before and the following apt-get dist-upgrade (nearly) worked like a charm.

But after this mess of an upgrade with the do-release-upgrade-script from 10.04 to 12.04 and similar problems on other Ubuntu release upgrades, I took the decision that any new systems definitely won't have Ubuntu any more, but the good, old, stable and reliable Debian, with which I never experienced such problems!

Hope this helps You too !

Best wishes - Ralph from Germany

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.