Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use 3 different languages on my laptop, but most of time I need only 2 of them, so switching with Ctrl+Shift is quite annoying. Is there a way to use Ctrl+Shift for 2 languages and have some special combination to temporarily switch to the 3rd one?

Note: there's very similar question, but in my question I'd like to make emphasis on switching between 2 languages with normal key combination.

share|improve this question

1 Answer 1

Remove languages from keyboard layout

Then From Dash choose keyboard settings and then click on shortcuts then add custom shortcut

choose a name and command similar to this

setxkbmap -layout en

enter image description here

Then click on the "Disabled " on the right to make you shortcut lets say Alt+Shift+1

Do it again for other languages you want

share|improve this answer
1  
Thanks for your answer, but as I said in my "note", I'm looking for a way to switch between 2 languages with normal key combination. E.g. I'd like to use Ctrl-Shift to switch between Lang1 and Lang2 and use, say, Alt-Shift to turn Lang3 on and off. –  ffriend Oct 13 '12 at 10:10
1  
you can do that also with answer above. Remove the third unused language from keyboard layout so you can use ctrl-shift with lang1 and lang2. Then create a shortcut for the third with the above answer. so you can user ctrl-alt for switching between lang1 and lang2 and the created shortcut for lang3 –  user61928 Oct 13 '12 at 10:14
1  
Check the updated asnwer –  user61928 Oct 13 '12 at 10:21
    
Unfortunately, it doesn't work. First of all, Alt+Shift doesn't have effect at all (maybe reserved combination or something like that), so I used Alt+Alt R (left and right Alt keys). After setting, when I pressed them for the first time it really switched layout... but it also broke Ctrl-Shift combination! That is, I had only one layout (Lang3) left, and to get Lang1 and Lang2 back I had to reboot the whole system. Also, in "Keyboard Layout" settings Ctrl+Shift is shown as active, and in layout list there are still Lang1 and Lang2, and nothing about currently active Lang3. –  ffriend Oct 13 '12 at 11:02
1  
ok then you should make a shortcut for each layout as prposed before. I think this is the only solution(maybe not) –  user61928 Oct 13 '12 at 11:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.