Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

An update has come named Linux kernel image for version 3.2.0 on 32 bit x86 SMP and it also says Geared toward 32 bit desktop or server systems with more than 4GB RAM. You likely do not want to install this package directly. Instead, install the linux-generic-pae meta-package, which will ensure that upgrades work correctly, and that supporting packages are also installed.

So what should I do? I do not want any problems. Also I've heard that kernel updates are problematic and I've received 6 of them.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Kernel images are tested just like any other update so if they appear in the standard update list then, unless you have a very unusual system, they are safe to install. Kernel updates are only problematic if you have unusual hardware or are using an custom made kernel.

The standard kernel releases are usually built with SMP and PAE enabled.

SMP (Symmetric Multi-Processing) allows software to use multiple processors or multiple cores, which many CPU's now have. If you have an older single core CPU, the kernel will simply switch of the SMP capabilities without a problem.

PAE (Physical Address Extensions) allows a 32-bit process to map address to more than 4GB. If you don't have that much RAM then, again, the kernel simply doesn't use the feature.

Since kernel upgrades often include security or bug fixes, if they appear in the standard software update list, then you probably do want to install them.

share|improve this answer
    
Thank you very much. –  rainlover Oct 13 '12 at 1:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.