Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My wireless is working fine, but when I login, it does not connect automatically, I have to select it from the list each and every time to use it. Even though the connect automatically option is selected in the network options.

So basically, after booting it, I don't get connected to the network until I choose connect to hidden wireless network, followed by selecting the hidden network, and clicking connect.

share|improve this question
    
Is the "available to all users" selected ? –  NikTh Oct 12 '12 at 22:54
    
@NikTh, That option is selected. –  oshirowanen Oct 13 '12 at 9:22
    
You can try to remove-delete the connection and create it from the begin.Open the network manager with gksudo nm-connection-editor –  NikTh Oct 13 '12 at 12:03
    
Just done that, and I am getting the same result. –  oshirowanen Oct 17 '12 at 19:31
    
Sounds like a bug. –  Thomas W. Oct 17 '12 at 19:48

2 Answers 2

The password is probably not saved in system settings.

To fix this:

  • Enter into "System settings -> Network"
  • Select Wireless in the left pane and click the Options button
  • Click the Wireless Security Tab.
  • Enter the password in the password field and click the Save button
share|improve this answer
    
I made sure the password was saved a long time ago, so this is not the problem. It doesn't want to automatically log me into hidden networks. –  oshirowanen Nov 11 '12 at 10:47

I had similar problem with my laptop running Ubuntu 12.10.

First thing first, make sure:

Connect Automatically and Available for all users are clicked in network settings.

And now, a small trick might work here. Once logged in and connected to wireless, just switch off the wireless physically (from the button) and start it again. From the next start/reboot (or may be couple of reboots), it will start auto connecting.

Now don't ask me why.

share|improve this answer
    
Done this a few times now, and it's still not remembering. –  oshirowanen Nov 13 '12 at 0:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.