Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Ubuntu 11.10 with Nautilus it was possible to tweak the appearance of desktop icons by editing nautilus.css as I had posted in How can I change the text colour on my desktop icons?.

In Xubuntu the same can be done by adding a few lines to one's .gtkrc-2.0 as described in How to highlight items on Desktop using xfce?.

In both cases, it is possible to assign colors to the various icon states (such as normal, selected and active).

Is it possible to do the same in Lubuntu? PCManFM seems to be responsible but I can't find any GUI or files to edit for the purpose. The default ~/.config/pcmanfm/lubuntu/pcmanfm.conf doesn't have any relevant settings.

share|improve this question

1 Answer 1

Assuming, you are willing to tweak the appearance of icon normal-text/selected text/ and the double clicked text and icon colors (selected and unselected), You can use Customize Look and Feel program.

The executable name is lxappearance. If it isn't installed, install it with the command below, if it isn't installed already

sudo apt-get install lxappearance

Then go to Lubuntu start menu → PreferanceCustomize Look and Feel to open it.

After opening it, Go to the Color tab. Then check the Use customized color scheme option.

enter image description here

Now you can change the icon colors and text and many others. I'm giving a hint of the corresponding items:

  • Selected items (Background) controls the color when you select it.

  • Selected items (Foreground) controls the color of the text when you select it.

The affected file is ~/.config/pcmanfm/lubuntu/pcmanfm.conf.

Hope this answer will help some. I'm still looking to change the text color of desktop icon when unselected. It seems there isn't any option there.

share|improve this answer
    
This is what I did to try your suggestion: I went in to the Color tab of Customize Look and Feel, ticked Use customized color scheme and changed the Background of Normal windows to green (#00ff00). I then opened a terminal and ran find ~/ -mmin -10 -type f. The relevant change was in this file: ~/.config/lxsession/Lubuntu/desktop.conf. I had previously asked about this issue over here‌​. –  user25656 Oct 23 '12 at 5:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.