Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

when i try to open avidio file like .mkv extension with mplayer it requires some multimedia plugin like gstreamer and and Ubuntu 12.01 freshly installed

and when i tell him to install them that Error appears to me :

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

 The following packages have unmet dependencies:

gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.2 is to be installed
                      Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed
                      Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                      Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                      Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                      Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                      Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
gstreamer0.10-ffmpeg:i386: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                           Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                           Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                           Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.2 is to be installed
                           Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed
                           Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                           Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                           Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                           Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed
                           Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.3ubuntu0.12.04.1 is to be installed

and i searched and found that the most solution said

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get install -f

and i tried them and nothing happen

and the content of my sources.list is

# deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120823.1)]/ dists/precise/main/binary-i386/

# deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120823.1)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Ubuntu 12.04.1 LTS _Precise Pangolin_ - Release amd64 (20120823.1)]/ precise main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://eg.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://eg.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://eg.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://eg.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://eg.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://eg.archive.ubuntu.com/ubuntu/ precise universe
deb http://eg.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://eg.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://eg.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://eg.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://eg.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://eg.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://eg.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://eg.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

so the question is how to install these plugin to can enjoy watching my Movies and videos

share|improve this question

marked as duplicate by Braiam, Jorge Castro, Seth, Alaa Ali, Kevin Bowen Sep 9 '13 at 18:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
can you show the contents of your apt sources? /etc/apt/sources.list –  niallhaslam Oct 12 '12 at 16:09
    
i showed the sources.list content int the question by editing it –  amrelghobary Oct 12 '12 at 16:10
1  
Did you install some PPA? askubuntu.com/questions/153311/mplayer-not-working-after-update –  Jorge Castro Oct 12 '12 at 17:01
    
i installed it ! nothing happened –  amrelghobary Oct 13 '12 at 2:58

3 Answers 3

up vote 1 down vote accepted

Looking at your error messages, I guess you either installed packages which are newer version than the standard repo (I might not the case) or installed packages which depends on the older versions of packages (Most probably) and it is not updated for the latest dependencies (thus requiring older versions).

I suggest you to do these: (most of the cases, it works)

  1. Install aptitude with sudo apt-get install aptitude command

  2. Try to install the package you are willing to install with command like

    sudo aptitude install <package-name>
    
  3. Aptitude will show you the error and present you a possible (best) solution. You will be asked to choose from 3 options with a message like

    Accept this solution? [Y/n/q/?]
    

    If you see that your desired package is not listed in the (will be) installed list, simply press n to let aptitude give you the next best solution. After several trial, (if you are lucky) you will see that your desired packages are in installable list and the packages causing the dependency problems will be showing in downgrade list. In this stage Press Y to accept the solution. The packages will be downgraded to satisfy to installation request.

I'm sorry that, I can't give you a demo run of aptitude like this, but you can check this page to see some of it's action.

share|improve this answer
    
the problem is that i don't know the name of the package because the program is responsible for choosing the plugins he want –  amrelghobary Oct 13 '12 at 2:40
    
The program name is gstreamer0.10-ffmpeg. –  Anwar Shah Oct 13 '12 at 3:28
    
thank you so much Olive the problem is solved –  amrelghobary Oct 13 '12 at 11:42

Clean your cache and redownload the packages sudo apt-get clean sudo apt-get autoclean

Try with sudo apt-get install -f , I've been getting these errors too.

Go to ubuntu software center >> Edit >> Software Sources >> Download From >> Select United States After that restart your computer go to software center and type wine and install it

sudo apt-get update to update your package list sudo apt-get autoclean to clean up any partial packages sudo apt-get clean to clean up the apt cache sudo apt-get autoremove will clean up any unneeded dependencies

Open the terminal and copy and paste all this code:

sudo apt-get clean &&
sudo apt-get autoclean &&
sudo apt-get autoremove &&
sudo apt-get update &&
sudo apt-get upgrade &&
sudo add-apt-repository ppa:ubuntu-wine/ppa &&
sudo apt-get update &&
sudo apt-get install wine1.5

IF THI NO WORK, TRY THIS: I suggest you to do these: (most of the cases, it works)

Install aptitude with sudo apt-get install aptitude command

Try to install the package you are willing to install with command like

sudo aptitude install <package-name>

Aptitude will show you the error and present you a possible (best) solution. You will be asked to choose from 3 options with a message like

Accept this solution? [Y/n/q/?]

If you see that your desired package is not listed in the (will be) installed list, simply press n to let aptitude give you the next best solution. After several trial, (if you are lucky) you will see that your desired packages are in installable list and the packages causing the dependency problems will be showing in downgrade list. In this stage Press Y to accept the solution. The packages will be downgraded to satisfy to installation request.

I'm sorry that, I can't give you a demo run of aptitude like this, but you can check this page to see some of it's action.

If, while doing this, you can identify the broken package, this command will very forcefully remove it:

sudo dpkg --remove -force --force-remove-reinstreq packagename Replace "packagename" with the real name, of course.

share|improve this answer

I had the same issue as you. You just need to be careful and only select the codecs for your architecture of device. To do so, make the window telling you about the codecs big so you can see the full name of the packages. If you have a 32-bit processor, select the ones with i386 at the end. But, if you have a 64 bit processor, choose the ones without i386 at the end.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.