Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is something that has happened since I upgraded to 9.10, but hasn't got fixed yet.
I'd like you to look at Blob And Conquer and some of his screenshots, like this one:

Defending the Blobs' homebase

Now, install the app from the Software Center (or by clicking here),
run it and start a new game. Then press Enter. What do you see? This:

Screenshot of a new game

Compare both screenshots. You don't see any texture! Try moving around with the arrows and rotating with the mouse. Even the weapons have no texture (compare the bottom-left corners of the screenshots).

My question is: why is this happening? What can I do to fix it?
I can even modify the code if needed. I guess this has something to do with SDL.

share|improve this question
    
I must add, I tried [un]installing any propietary drivers and it makes no difference. I've tested on multiple computers. –  jmendeth Oct 12 '12 at 16:02
    
Just tested it on a ATI HD5670 with proprietary drivers and I am not getting any textures either. So it's probably a bug in the game. –  Grumbel Oct 13 '12 at 1:04
    
@Grumbel I'm pretty sure the source code is exactly the same that worked on 9.10. So it can't be a bug in the game, at least directly. –  jmendeth Oct 13 '12 at 10:12
    
@Grumbel Solved it, finally! See my answer. –  jmendeth Dec 26 '12 at 15:51
add comment

2 Answers

up vote 1 down vote accepted

@Grumbel Well, I was right. The source code hasn't changed so it can't be a direct bug in the game.

It results that all the textures (they were on a separate package that I didn't look into) have been deleted and replaced by one-pixel images. Maybe because of copyright restrictions.

What I know:

The textures were present on version 1.7, but absent on 1.10.
Both versions are, at the time of this writing, present on the archives.
Notice the size difference between both versions of blobandconquer-data.

Therefore, you should try to install 1.7,
or manually download and install each 1.7 package from the archives.

share|improve this answer
add comment

You are right, it's a copyright issue, some more info can be found in:

/usr/share/doc/blobandconquer-data/NEWS.Debian.gz

blobandconquer (1.11-dfsg+20-1) unstable; urgency=low

Music, sounds and textures are non-free.

Earlier versions of blobandconquer were released in Debian main with music,
sound and textures, since it was though that they were in the public domain or
otherwise freely licensed. However, it was brought to the attention of
upstream's main author that this was not the case for many files. The sound,
music and textures files have been downloaded from various free online
repositories, such as (but not limitted to) modarchive.com. These repositories
allow free use and redistribution of the files, but not necessarily
modification or commercial use. Therefore, the music, sounds and textures in
Blob and Conquer are not DFSG compliant, and cannot be distributed in Debian's
main section.

The game should still be playable, and in the future replacements will be found
for the removed game assets.

-- Guus Sliepen <guus@debian.org>  Sat, 21 May 2011 14:38:59 +0200
share|improve this answer
    
Good to know. Thanks! So while replacements are found, maybe the data package put in the restricted section... Also, it'd be good to know which of the textures was non-free, since there are some really basic textures... –  jmendeth Jan 2 '13 at 11:47
    
An alternative package (with all the textures) shall be put on restricted or Medibuntu. I'll see if I can do it... –  jmendeth Jan 12 '13 at 9:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.