Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Prior to Ubuntu 11.04 I could configure grub so that after the menu is displayed and the system is booting detail of the boot activity appears. Now there's just a blank screen between the menu and gdm login.

How do I coax Ubuntu 11.04 to display the boot activity? Dale E. Moore Oh yeah; I asked the same question here http://ubuntuforums.org/showthread.php?t=1760753 and they didn't know the answer.

This question was asked here https://answers.launchpad.net/ubuntu/+source/grub2/+question/160511 too, with no new insight.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Grub is a boot loader, i.e. the software that is launched when the computer starts and whose role is to boot an another operating system. So, unless I have misunderstood, what you want is not seeing the messages from Grub, but instead you want to see the messages from Ubuntu itself during the boot process.

Generally speaking, what you have to do is to remove the "quiet" Linux command line option. However in recent versions of Ubuntu, this is not enough because the splash screen has not been designed to display activity. Therefore, you also need to prevent the splash screen from starting up, and you can do that simply removing the "splash" command line option.

In other words, you should edit some configuration so that your /proc/cmdline changes from:

BOOT_IMAGE=/boot/vmlinuz-... root=... ro quiet splash ...

to:

BOOT_IMAGE=/boot/vmlinuz-... root=... ro ...

To do that, you need to set GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub to an empty string:

GRUB_CMDLINE_LINUX_DEFAULT=

We are almost there: now you need to remove the so called gfxpayload and vt_handoff. While these two options improve the boot experience, they will also prevent your messages from being displayed. AFAIK, there are no options in /etc/default/grub that you can tweak for that, so you are forced to open /etc/grub.d/40_custom and add the following at the bottom of the file:

function gfxmode {
    set gfxpayload=
    set vt_handoff=
}

Simple, but effective.

share|improve this answer
    
Thanks Andrea; that's better! Now I get a grub menu, 1 second blank screen, Ubuntu progress, 1 second blank screen then gdm. –  Dale E. Moore Oct 13 '12 at 11:27
    
With "Ubuntu progress" do you mean the "Ubuntu" word with the five dots below? It this is the case, then it means that there's still the splash command line option. Please, post the content of your /proc/cmdline and possibly also your /etc/default/grub. Thanks! –  Andrea Corbellini Oct 13 '12 at 15:27
    
I mean the Ubuntu boot activity; no splash here... RyCycle ~ # cat /proc/cmdline BOOT_IMAGE=/boot/vmlinuz-3.2.0-31-generic root=UUID=db391a50-406e-45d2-b35e-33dbb628e929 ro RyCycle ~ # cat /etc/default/grub GRUB_DEFAULT=0 GRUB_TIMEOUT=3 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="" GRUB_CMDLINE_LINUX="" –  Dale E. Moore Oct 13 '12 at 18:16
    
Well, if you see the Ubuntu boot activity then the problem is solved, isn't it? –  Andrea Corbellini Oct 14 '12 at 7:34
    
You might not have noticed that I marked your answer as the solution to my problem. Thanks for your help. –  Dale E. Moore Oct 14 '12 at 13:22
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.