Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How can I fix a 404 Error using a PPA?

I am unable to fetch updates from the updates server. The screenshot above shows the message I got when trying to upgrade:

enter image description here

W: Failed to fetch http://ppa.launchpad.net/tldm217/tahutek.net/ubuntu/dists/quantal/main/source/Sources  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/tldm217/tahutek.net/ubuntu/dists/quantal/main/binary-amd64/Packages  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/tldm217/tahutek.net/ubuntu/dists/quantal/main/binary-i386/Packages  404  Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
share|improve this question

marked as duplicate by Jorge Castro, LnxSlck, devav2, Mitch, Mik Oct 13 '12 at 19:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Would you try to type 'sudo apt-get update' in a terminal and report what the output is ? –  alci Oct 12 '12 at 12:26

1 Answer 1

Hmm, a 404 Page Not Found error. I'd recommend starting off with some basic internet troubleshooting:

  • If you're using Wi-Fi, disconnect then reconnect.
    • If that doesn't fix it, try rebooting the router.
  • Can you load any pages at all? If not, get the bugs worked out of your internet. When you can reliably browse the web, try again.

If basic internet troubleshooting isn't cutting it, try temporarily changing your DNS (don't worry; this is not permanent, and is much easier than it sounds!)

  1. Go to the Network Connections manager. (Click on your connection icon in the system tray and choose Edit Connections. The one accessable via the System Settings panel doesn't have what we need.)
  2. Go to the appropriate tab (Wired/Wireless) and click New. Name it something like "Home Wi-Fi (OpenDNS)" or "McDonald's Wi-Fi (OpenDNS)" or "Auto Ethernet (OpenDNS)".
  3. Enter the details of your connection, but don't click Save... just yet.
  4. After you have all the appropriate details set up, go to the IPv4 Settings tab. (This procedure is identical for both Wired and Wireless.)
    Choose Automatic (DHCP) addresses only.
  5. Okay, brace yourself, this is the really, really hard part, I mean it:
    Under DNS Servers, enter 208.67.222.222, 208.67.220.220. Now click Save....
  6. Disconnect from your internet, then (re)-connect to the connection you just created.
  7. Now, type:

    sudo apt-get update
    sudo apt-get upgrade
    
  8. After you're done, go back to your "Normal" connection, or, just stick with OpenDNS. It is faster in most cases.

If all that still didn't fix it, perhaps you added a software source with a typo? That happens to the best of us... (aka me :P)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.