Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

concerning How do I get a Ralink RT3060 wireless card working?

I'm running Ubuntu 12.04 with a 'LWPX07 Edimax EW-7711In 150M 1T1R WL PCI Card' which has a rt3060 chip. Out of the box the card is recognized as rt2800sta. I tried solution one, that didn't work. Still the card connects to the wireless network, but it seems to slow to load any pages.

Then I tried solution 2, but then the network-manager doesn't see any wireless device.

$ iwconfig
lo        no wireless extensions.
ra0       Ralink STA  
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  invalid crypt:0  invalid misc:0
eth0      no wireless extensions.

$ lsmod
Module                  Size  Used by
rt3562sta             882296  0

$ lspci -v
05:02.0 Network controller: Ralink corp. RT3060 Wireless 802.11n 1T/1R
    Subsystem: Edimax Computer Co. Device 7711
    Flags: bus master, slow devsel, latency 64, IRQ 23
    Memory at ff9f0000 (32-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: rt2860
    Kernel modules: rt3562sta, rt2800pci

Am I missing a configuration step? How do I tell the network card which driver to use?

share|improve this question
Can you please answer your own question with that? Thanks – Amith KK Oct 13 '12 at 8:32
Don't use sudo su, use sudo -s Or much more appropriate for your commands, make && sudo make install make doesn't need admin priviledge, but install does. – user135081 Feb 24 '13 at 1:15

Stephan solved the problem in his question:

I found the problem. As described in stevens blog

sudo su
make && make install

"You need to use sudo su and not just sudo so it creates the directories properly." That is the problem with the solution describe above.

share|improve this answer

Well, as luck would have it, I am using the exact one on a Raspberry Pi. I also tested the Wireless device on 13.04 and after ~2 minutes, the connection dropped. It was detected but not working on 12.04 and 12.10, so I have to grab the drivers from the official site and compile them.

Here are the steps similar to the Official Edimax GOfficial Edimax guide for Ubuntuuide for Ubuntu:

  1. Go to the Edimax Site

  2. Download the Latest Drivers

  3. Extract the downloaded file (You need to extract the file 2 times. the first because of the ZIP format, the other is for the tar.gz) and open the newly created folder. The folder should be called 2010_07_16_RT3062_Linux_STA_v2.4.0.0. I recommend extracting the folder in your Desktop folder or home folder so it is easier to get to. Then go to the terminal and type the following (Assuming it is on the desktop):

    cd ~/Desktop/2010_07_16_RT3062_Linux_STA_v2.4.0.0
  4. Blacklist the default module for this Wireless Driver (This way, when you use the new driver module it works without creating a problem with the older one):

    sudo gedit /etc/modprobe.d/blacklist.conf

    Add at the bottom of the file the following line:

    blacklist rt2800usb  
    blacklist rt2800pci

    And save the file.

  5. Now go to 2010_07_16_RT3062_Linux_STA_v2.4.0.0/os/linux/ and edit the file

      Change the following variables:


      change it to 


      and save the file.

    NOTE: When opening the file, do not only change the HAS_NATIVE_WPA_SUPPLICANT to a value of y, but also do it with HAS_WPA_SUPPLICANT in case it has n. In my case it had y but it should be checked to make sure both WPA_SUPPLICANT are set to y.

  6. Go to your main extracted folder (It should be the 2010_07_16_RT3062_Linux_STA_v2.4.0.0 folder) and type the following:

    sudo apt-get update && sudo apt-get install build-essential linux-headers-generic
    sudo make install
  7. If everything compiled correctly do the following:

    modprobe rt3562sta
  8. If step 7 runs without any problems, we add the module to the list of modules to loaded upon every boot:

    sudo gedit /etc/modules

     and add a line at the end of the file that says rt3562sta.

    Save and exit. I recommend rebooting to see and check the device.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.