Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use x11 and awesome as my WM. I would like to completely disable the mouse, that is mouse clicks, mouse wheel, mouse movement, display of the cursor, etc.

Is there an easy way (I would prefer a disable/enable bash script)?


share|improve this question

For the mouse, proceed as follows. Use xinput list to find out your mouse devices. Disable with

xinput set-prop 12 "Device Enabled" 0

to enable it again, type

xinput set-prop 12 "Device Enabled" 1

where 12 is the id of your device. Given that the mouse cursor disappears if mouse is inactive, you need not to worry about that (if it doesn't, you can use unclutter)

share|improve this answer
OMG, so nice, especially with Ratpoison WM. – Joe Corneli Jun 14 '15 at 13:52

Another answer to your question is to unload the module that is responsible for.

sudo modprobe -rvf psmouse


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.