Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought a new Lenovo P580 Ideapad yesterday and installed 12.04 64bit on it. I tried making a call with it and discovered that the built-in microphone wasn't working. I unmuted it in sound settings, and still nothing.

I did the following

:~$ cat /proc/asound/card0/codec#* | grep Codec 
Codec: Conexant CX20590
Codec: Intel PantherPoint HDMI

Followed some tips and ran

:~$ sudo gedit /etc/modprobe.d/alsa-base.conf

then added this to the end

options snd-hda-intel model=asus

I amplified the input sound with alsamixer to make sure... When the input was amplified to max on alsamixer, the input signal was at a constant level (1/3 of max) which I'm guessing was the system's noise. This played back was a low frequency hum. I plugged in headphones that have a built-in mic and that worked, although it still had the humming in the background.

I changed the last line in alsa-base.conf to:

options snd-hda-intel model=thinkpad

which gave me the same result.

I'm not sure where to go from here, and any help would be greatly appreciated...

share|improve this question

3 Answers 3

You should try to install the lastest drivers for your devices. If you didn't do it yet, follow the next steps:

  • Click on the Dash
  • Search for Additional and click Additional Drivers
  • Wait a bit, and you'll see a list with all the compatible drivers for your computer. Look if there is any microphone-related driver listed.
  • Check if it appears at that list, select the entry for it and click Activate. After a while, maybe you'll have to restart your computer.

I hope it works to you, and tell us soon if it worked OK!

share|improve this answer
    
Thanks for your quick response. I had tried looking at the additional drivers already but nothing had come up. It says "No proprietary drivers are in use on this system". Any other thoughts/ideas? –  intanethi Oct 12 '12 at 16:37
    
Well, I had some problems with my headphones jack and adding-and-testing lines to alsa-base.conf worked in the end, so I'd recommend you to try different configurations on that file, restart and try. –  Addison Montgomery Oct 12 '12 at 16:48
up vote 0 down vote accepted

In terminal run:

sudo gedit /etc/modprobe.d/alsa-base.conf

Add these two lines to the end of alsa-base.conf :

alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

Save and reboot.

After reboot make sure that your mic is not muted. To check that run alsamixer in terminal.

Credit to Mark Rijckenberg

share|improve this answer

My laptop is a Lenovo Ideapad S210 Touch. My internal mic was not working in Ubuntu 13.10. Adding the line

options snd-hda-intel model=laptop-amic

to the file:

/etc/modprobe.d/alsa-base.conf

fixed my issue. I hope this will help someone having the same issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.