Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual boot laptop, of lubuntu and windows 7. I really like ubuntu, and I rarely boot on to windows 7 now. However, one issue that I could not resolve, was that my hard drive heats up on every ubuntu variant that I have tried. I already have tried cleaning dust out of my laptop,and proprietary graphic drivers (Nvidia Gt540M) are installed, and bumblebee is running well.

I have googled around for a solution, and have experimented with laptop-mode-tools, and powertop. They did little towards solving the overheating issue. My hard drive still hits 60+ degrees celcius when running on AC.

The hard drive temperature reaches 60 degrees when connected to AC, and the palmrest, located right over the hard drive, becomes very warm, bordering on hot. Is there any way to reduce hard drive heating? I really like Lubuntu,and am not willing to move to another distro.

share|improve this question
    
I have this same problem. Playing games in Windows 7 is always fine, whereas Ubuntu overheats my hard drive (as shown by smartctl). –  Sparhawk Mar 11 '13 at 22:46

2 Answers 2

I think it might be because of the temporary swap partition that Ubuntu uses... that is if Ubuntu is installed after Windows7. I also have the same issue with my Thinkpad SL410

share|improve this answer
    
In my case, I have plenty of RAM, and swap is never utilised. Do you see usage of swap in your situation? –  Sparhawk Jan 3 at 5:17

Here's the solution:

laptop-mode-tools is controlling power management for your hard drive, and you need to configure it appropriately for your situation.

Open /etc/laptop-mode/laptop-mode.conf for editing with root privileges, and around line 276 (on Ubuntu 12.04), change this value to 600

NOLM_HD_IDLE_TIMEOUT_SECONDS=7200

This is the amount of time before your drive is told to "spin down" or idle on AC power. 10 minutes with no read/write activity is reasonable.

And around lines 290-291 (on Ubuntu 12.04), change both these values to 1:

LM_AC_HD_POWERMGMT=254

NOLM_AC_HD_POWERMGMT=254

These set the power management level granted to the drive, with 1 being "full" power management, and 254 being "almost zero" power management. The latter setting is the reason for your temperatures, because you can set the level, but how the drive manages power at a level is entirely up to it -- it completely depends on the implementation in the drive's firmware, and can vary by model, manufacturer, etc.

With the changes, we are now telling the drive to perform the same power management it does while on battery (which is satisfactory for you). This is different from simply allowing the drive to spindown while on AC (as in @EliahKagan's answer), because that would still leave the drive's power management set to near zero at level 254.

How to determine power management level

To find out the current level, while on battery, AC, or any other situation:

sudo hdparm -I /dev/sda | grep Advanced (replace sda appropriately)

Source and credits: Hard drive overheats when laptop running on AC power

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.