Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

I have a fresh install of Ubuntu on my laptop. This MAY be a duplicate question, by my situation seems to be slightly different from other people who are/were experiencing similar issues so I thought it would be best to open a new question. It is similar to this question, but not exactly the same.

I also want to preface this with the knowledge that I am a Linux noob. I installed Ubuntu on my laptop with the express purpose of learning Linux. That being said I am a Computer Sciences major and have worked in IT for years, just entirely in a Windows environment. So while I am pretty computer...savvy in general, I don't know much in the way of *nix command line commands and such.

Anyways, I installed Ubuntu from the Live CD. I did run into some trouble installing it where I would get a black blinking cursor, but was able to get around it by setting the nomodeset parameter (similar to what is referenced in the first answer to the question I linked above).

So anyways, got it installed, worked great, grabbed all the updates from the Ubuntu Software center, grabbed a few updates, practiced using SSH to get into my Linux account in my school's computers, etc etc.

But now issue is I intermittently get the same black blinking cursor option on bootup. It makes it to the OS selection screen every time, but sometimes it will boot up fine, other it hangs on the black screen with blinking cursor after I choose an OS to boot into. Can't seem to figure out what the determining factor is. If it happens, I just manually reboot 2 or 3 times until it goes away, but it really is frustrating, and a bit worrisome because (and this could be my imagination) but it seems to be increasing in frequency. For example, I have gotten one successful boot out of 7 attempts while writing this on my desktop.

I got the impression from the linked question above, and from a few other forum posts, that this is usually caused by a graphics card driver incompatibility with ATI or Nvidia graphics cards, and that that's where the nomodeset parameter comes in. HOwever, my laptop is using integrated Intel graphics. Also, in my experience, driver incompatibilities, especially ones that stop your computer from booting, aren't usually intermittent. Either they work or they don't manually rebooting a few times doesn't make the problem temporarily go away.

Also I did try setting the nomodeset parameter by pressing 'e' on the OS selection screen, and it still hung up, though this time it hung up on a purple screen, no text. The next time I tried it with nomodeset I got a bunch of text and it hung up on:

[0.305025]   NMI watchdog enabled, takes one hw-pmu counter.
[0.305129]   Booting node  0, Processors #1
[0.424438]   NMI watchdog enabled, takes one hw-pmu counter.
[0.424542]   #2
[0.532213]   NMI watchdog enabled, takes one hw-pmu counter.
[0.532320]   #3

I also tried booting into (recovery mode) and it made it to:

[0.305025]   NMI watchdog enabled, takes one hw-pmu counter.
[0.305129]   Booting node  0, Processors #1
[0.424438]   NMI watchdog enabled, takes one hw-pmu counter.
[0.424542]   #2

The only thing that struck me as being out of sorts during the boot was the line:

[0.312575] PEBS disabled due to CPU errata

In case this helps the laptop is the Asus UA46E-BAL7. I do not having any USB devices plugged in. Also it is dual-booting with Windows 7, though I had not yet booted into Win7 until after this happened, merely to test to see if that was having trouble as well (so far seems to boot fine every time). While it is brand new to me, it was a refurbed so a hardware issue isn't out of question, and the text logging seems to indicate a CPU issue, but that doesn't explain why it works fine in Windows.

Again, if this was a Windows machine I would be able to troubleshoot it. Boot into safemode, check for driver incompatibilities, run any one of the bootable hardware diagnostic disks I have, perform a repair installation of Windows, etc. But for Linux I don't know where to begin.

share|improve this question

marked as duplicate by Jorge Castro, Stephen Myall, Mitch, hexafraction, Tom Brossman Oct 12 '12 at 21:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Well not it won't seem to boot at all no mater how many times I try. Beginning to think it's a heat issue so I am letting it cool off, but it still boots into Windows fine every time without a hitch so... –  Taylor Huston Oct 12 '12 at 6:32
    
Yeah, let it sit for 15 minutes, booted right up. Also seems to be running a lot cooler. Like during the boot process it blows out a significantly larger amount of hot air out the side then when it's all booted and just sitting there. Going to run a burn-in HW diagnostic overnight, any other suggestions? –  Taylor Huston Oct 12 '12 at 6:52
    
Memtest ran all night, no errors. Almost seems to be a heat issue, hence the letting it 'cool down' to fix it, and there seem to be a few other posts about 12.04 causing laptops to run hot, though couldn't find any mentions of that heat issues causing the trouble I am experiencing. –  Taylor Huston Oct 12 '12 at 15:15
    
@jorge I don't think this is a duplicate because the selected answer for that post seemed to indicate that this was caused by an incompatibility with ATi and Nvidia graphics cards, which I do not have. I am running Intel graphics. Also that post seemed to indicate that the laptop would fail to boot every time, not intermittently like mine is. I think I may be experiencing similar symptoms, but seems to be a completely different (possibly heat/cpu related?) cause. –  Taylor Huston Oct 12 '12 at 15:17
    
This answer should help you solve the problem. –  Aditya Feb 20 '13 at 13:00

1 Answer 1

I may have fixed this issue.

Added apic to grub based on These instructions.

Not entirely sure what that does or why it fixed it, from what I could tell apic is related to power saving options, but my laptop seems to be running smooth quiet and cool so I should be in the clear.

Any potential issues I should be on the lookout for having that disabled?

share|improve this answer
    
Having a completely different graphics card (AMD Radeon HD 7870) I think it was the noapic parameter which seems to have fixed it for me now - hoping that it really doesn't appear anymore now ;)! –  codeling Sep 20 '13 at 15:31
    
Turns out the ..apic stuff was not helping at all for me. In my case it was the login manager having a race condition, see here: askubuntu.com/a/350857/38837 –  codeling Sep 27 '13 at 18:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.