Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to use Jack audio to prevent clicks but I'm having problems getting jack to play though my usb wireless g930 headphones.

I'm using puredata and I can get my usb wireless g930 headphones to work with the Alsa setting but Jack will only play through the speakers. Does anyone know how I can get jack to play through my headphones?

Thanks

PS I'm using ubuntu 12.04 64bit

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

You need to use jack and pulseaudio together. Here's what needs to be installed along with a youtube video

1) sudo apt-get pulseaudio-module-jack
2) sudo gedit /etc/pulse/default.pa
add lines load-module module-jack-sink and
load-module module-jack-source 

See video

http://www.youtube.com/watch?v=6J-RQudJx30

share|improve this answer
add comment

This was tested to work with ubuntu 12.04 Host and ubuntu 10.04 guest. in virtualbox 4.1.22

1) launch pulseaudio volume control in your host system.
2) launch your virtualbox guest OS (ubuntu 10.04)

3) change setting to logitech g930 view second image

enter image description here

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.