Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed vino, but when I run it, I get the following error.

# ./start_vnc 

(vino-server:2502): EggSMClient-CRITICAL **: egg_sm_client_set_mode: assertion `global_client == NULL || global_client_mode == EGG_SM_CLIENT_MODE_DISABLED' failed
** Message: The desktop sharing service is already running, exiting.

MORE DETAILS: UltraVNC client running on a Windows computer can login and shows the Ubuntu desktop, and controls the Ubuntu mouse to do things, but the VNC client view at the Windows computer does NOT show any changes to the display at the Ubuntu desktop, only the original desktop view at the time of VNC client login.

UPDATE I solved it by following the askubuntu post: VNC session very slow in 12.04 compared to older versions, which said to do this:

gsettings set org.gnome.Vino disable-xdamage true

..and it worked.

But should I be concerned about the error messages?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.