Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My system: Ubuntu 12.04 LTS. My graphic card: nVidia GeForce gt430. My monitor is Samsung LE26R51B. And my connection is digital (HDMI).
The current screen resolution is not good at all, I can't see the top bar and the left one.

Here are the available resolutions in settings:

1920*1080
1280*720
960*600  
and lower resolutions

But with no one of these I can see the top bar in it. They are bigger than the monitor.


In Windows 7 I use 1202*670 resolution.

How can I change the resolution to what I want exactly?

share|improve this question
1  
It's rather complicated, but have you checked out this guide? – SirCharlo Oct 11 '12 at 14:56
1  
i get this error: xrandr: Failed to get size of gamma for output default – Dz WarSoldier Oct 11 '12 at 15:59
    
@SirCharlo I know your comment and this question are rather old, but I found your link to work quite well. Do you think you can add the gist of that as an answer? – Nil Jun 26 '13 at 14:56

Using 12.04 LTS with a Samsung SyncMaster 923NW

Before you do anything find your native resoultion. Mine is 1440x900.

First find your display output name by typing: xrandr

Mine was 'VGA1'

The guide was tricky but this worked for me even though the tutorial said do something different. Replace the resolution with your monitor's specifications and the output.

sudo xrandr --addmode VGA1 1440x900_60.00

share|improve this answer
    
According to this link, which has been quoted in the top answer, xrandr is run without sudo. May be useful to explain why sudo is used here? – clearkimura Feb 19 at 7:34

Open a terminal and enter:

xrandr

It will output possible resolutions. To set 1202x670 enter:

xrandr -s 1202x670

See here if you need to add new modes.

share|improve this answer

You may be able to set the right resolution and also change the driver via a graphical interface by installing the utility called nvidia-settings. I've used it on my desktop many times.

sudo apt-get install nvidia-settings

share|improve this answer

This may seem like a silly suggestion, but have you tried using the monitor's buttons/on-screen display to change how the screen is displayed? There should be an "Auto-adjust" item.

Additionally, 1202x670 sounds like a very strange and non-standard resolution. While it's not in the list that you provided, have you tried 1360x768 instead?

share|improve this answer

First I'd try to install the nvidia binary driver (there's a tool named "Additional Drivers" or "Jockey" that will assist you). If that doesn't help, you've won the Jackpot. Your prize is editing the xorg.conf file.

First have a look at this xkcd comic: https://xkcd.com/963/

Be warned that if you misconfigure xorg.conf, you might end up without a graphical session, just with a command line. Don't worry, you can simply (backup and then) delete xorg.conf and the graphical session should work again.

Then have a look at that guide: https://help.ubuntu.com/community/NvidiaResolutionXorgConf

Depending on the driver you are using, you might need to put a different driver in xorg.conf - for the binary nvidia driver it's "nvidia", for Nouveau it's "nouveau" I think, and for the old nv-driver it's "nv".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.