Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a USB turntable which when plugged in to my ubuntu 10.10 machine appears in the audio settings as an input device (USB PnP Audio Device Analog Stereo) like a microphone.

What I'd like to be able to do it to have the sound for that audio device played back through the audio output (speaker or whatever). I'm not too worried if there's a slight delay between the audio coming in and it being played out through the speakers.

As far as I'm aware this is refereed to as software loopback. I can achieve exactly what I want if I open Audacity, enable software loopback and press record. Obvious this isn't ideal as I don't really want it recording what I'm playing all the time.

I know this is possible because of the Audacity example however I'd like to know if there's a way to do it without it recording. I've search around for a while for a piece of software that does this, however I couldn't get anything even close.

Any help would be greatly appreciated.

share|improve this question
    
+1 Yes! I'd like this too. I'd like to use my pc speakers to play music from my Squeezebox which is hooked up to my line-in. –  Torben Gundtofte-Bruun Jan 3 '11 at 19:28

1 Answer 1

up vote 8 down vote accepted
+50

Just a warning: This answer is theoretical, because i don't own such hardware...

AFAIK you have to enable a loopback-device for pulseaudio:

pactl load-module module-loopback

After that you should see a new application under audio-settings.

If it works well, you may add a line to the pulse-audio-config to make this persistent:

sudo sh -c ' echo "load-module module-loopback" >>  /etc/pulse/default.pa '

Good luck!

Additional info from matto1990:

You only need to do this if you want to loopback from a device other than the microphone or line in (the default ones). Go to software center and install "PulseAudio Volume Control". Open it up and go to the recording tab. In the show dropdown select "all". In the "loopback from internal audio" section (or whatever the output device you want is) select the input device you want to loopback from (in my case the USB one).

share|improve this answer
    
I get a new thing under the application tab. It has no icon (the grey square with the red circle strike through icon). It's on full volume and not muted but nothing is coming out of the speakers. I've made sure the USB device is selected as the input device. –  matto1990 Jan 6 '11 at 22:52
    
Actually it does seem to work but it loops back the microphone built into the laptop. This happens irrespective of which device I select under the input tab. How would I go about telling it to use a different device? –  matto1990 Jan 6 '11 at 22:55
1  
Ok, I've found the way to do it. You only need to do this if you want to loopback from a device other than the microphone or line in (the default ones). Go to software center and install "PulseAudio Volume Control". Open it up and go to the recording tab. In the show dropdown select "all". In the "loopback from internal audio" section (or whatever the output device you want is) select the input device you want to loopback from (in my case the USB one). After you do this it works perfectly :D Thanks Clausi :D Can you add it to your answer for future reference please :) –  matto1990 Jan 6 '11 at 23:07
    
Glad it works! I have added your comment to the answer. –  Clausi Jan 7 '11 at 9:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.