Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run QBittorrent for torrenting on Ubuntu, and I have it set to drop downloads in the same hard drive, but on a different partition from what the OS runs on. Before I'm able to start downloading, I have to manually navigate to the file path of the hard drive, as if the system has no access to it until I manually go and visit it.

While I CAN manually access the hard drive prior to opening the program, it's extremely annoying to get 20 errors flashing when I forget to.

Is there a way to over ride this other than installing to a different location? I have my partitions setup in a way that it would be difficult to do it any other way (windows is on my other internal).

share|improve this question

3 Answers 3

You need to add your partition to the /etc/fstab file so that it's automatically mounted. Extensive documentation is available on the net on how to add a partition to fstab so you should be able to do it easily.

Cheers,

share|improve this answer

I think automouting the disk partition at boot time can solve your issue. You will need to edit /etc/fstab file and enable automount for the specific drive there. There is a good tutorial for automounting here http://www.webupd8.org/2011/11/how-to-mount-partitions-automatically.html.

share|improve this answer

You must mount permanently the partition.

Here in Ubuntu community we have a very good documentation and a wiki page.

First read Introduction to Fstab so you can understand better what you will do and then read automatically mount partitions to see how you can mount permanently your partition.

Thanks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.