Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I dont know what's wrong with my update manager..

It says that the softwares that I installed was broken. Maybe because I force shutdown my laptop, because Ubuntu wont shutdown,showing up desktop wallpaper but not title bar and launcher, but It won't shut down (+that's another bug).

I've just update the broken softwares. the size is 60 to 70 MB..

But It doesn't work. Now I cannot update or install any software from Update Manager or Ubuntu Software Center. Can anybody tellme what's wrong?

This is what appears when I use Update Manager

I use Ubuntu Software Center, and this message appeared

This is what appear when I open Ubuntu Software Center

I chose repair and when it update the broken softwares using Ubuntu Software Center.
It failed. And show up this message.

The problem is I can't update or install any program from Ubuntu Software Center and Device Manager anymore. (I closed allprograms include ubuntu software center,and device manager in this case). Some one helpme?

I tried to use apt-get install -f in terminal but it shows message like this:

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

share|improve this question
2  
Why you didn't use sudo apt-get install -f in terminal? –  lambda23 Oct 11 '12 at 9:42
1  
Note the sudo in the above comment. –  Javier Rivera Oct 11 '12 at 9:43
    
I tried but it shows this error in terminal.. –  Widy Graycloud Oct 11 '12 at 10:32
    
No apport report written because MaxReports is reached already No apport report written because MaxReports is reached already Errors were encountered while processing: winbind libpam-winbind netpbm wine1.3 E: Sub-process /usr/bin/dpkg returned an error code (1) –  Widy Graycloud Oct 11 '12 at 10:33
    
Try sudo rm /var/lib/dpkg/lock and then the sudo apt-get -f install again. Also, please do not use caps to draw attention to a question. Consider investing time n the site and gaining reputation, and then offering a bounty. –  hexafraction Oct 11 '12 at 10:40

1 Answer 1

please visit the Package manager troubleshooting procedure in Ubuntu community help wiki

Follow the instructions (steps) carefully and your problem will be solved.

Thanks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.