Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been trying for a few days now, but cant seem to be able to setup a passwordless login using rsh in Ubuntu 12.04 server 64bit.

Before shooting me down and telling me to use ssh, this is my reason: Im setting up a cluster, and its huge. I want to be able to connect to any machine from any machine. Its a safe isolated network. The cluster uses MPI, which worked fine with rsh on older Red Hat Linux. Its silly to make key pair for every machine on every machine just to use passwordless SSH, hence the question. Also, ssh is slightly slower.

I tried everything, editing the .rhosts file, hosts.allow, hosts.equiv, etc.

Nothing seems to work. Please help.

share|improve this question
I haven't used rsh, so I'm just attempting to look stuff up regarding this, but does the .rhosts file have 0644 permissions? – Chuck R Oct 11 '12 at 7:30
Can you provide the output of rsh from the command line when you try to log in using verbose mode? – niallhaslam Oct 11 '12 at 9:35
Yes, I set the .rhosts to 0644. Do I have to reset the rsh-server daemon? How do I do this? – Vishnu Oct 11 '12 at 10:22
How do I use verbose mode? I think that is only for ssh. – Vishnu Oct 11 '12 at 10:41
up vote 1 down vote accepted

OK, I finally figured out why I cant get it to work.

My user name must be the same on both local and remote machines in order to use .rhosts or hosts.equiv for passwordless login.

Different names wont work.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.