Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have successfully managed to load subtitles in totem and it says that the subtitles are run but,the problem is that I can't see them. Does anybody know a fix for it?

share|improve this question
2  
Can you see some text garbled or there is no text displayed at all? –  Pavlos G. Jan 3 '11 at 17:54
2  
Go to Edit --> Preferences, and then see the following option is checked "Automatically load subtitle files when movie is loaded". –  karthick87 Jan 3 '11 at 17:59
1  
Try testing it with VLC. If VLC can see them then we know the subtitles are ok (No wrong code in them). Follow what karthick87 said and remember to have the subtitle in the same folder as the video with the same name as the video (Eg: Rambo3.avi / Rambo3.srt) –  Luis Alvarado Jan 3 '11 at 18:07
    
I know the subtiles are ok because they work in windows/ –  Eitan Fishman Jan 4 '11 at 11:40
1  
Also I checked the "Automatically load subtitle files when movie is loaded" option and it didn't do anything. –  Eitan Fishman Jan 4 '11 at 11:41

2 Answers 2

Okay When a DVD is ripped via Windows it does not save the subtitles in a separate file it simply lays the text in an overlay on the .VOB file.

I installed gstreamer-plugins-ugly and gstreamer-plugins-bad plus the dependencies again using the --reinstall command.

After re-ripping the DVD and creating a .sub file from the subtitle file on the DVD I have managed to load the subtitles in Totem without a problem.

It seems that Totem, even with the restricted plug ins and additions from the MediBuntu PPA can not read the subtitles from ripped DVD's although it can from traditional DVDs i.e. on a disc.

You can however, if you already have ripped DVDs or videos with subtitles simply create a .sub file in a text editor and save it in the Root of the DVD folder. Once saved you can open the file you have created by selected "Select text subtitles" This will load the file and display the subtitles as an overlay on the screen.

As with AVI files CYREX had it 100% as long as the .avi and the .srt file are named the same and in the same folder you can open the file and activate subtitles from the right click menu.

share|improve this answer

I would suggest trying it with vlc, and checking the font preferences, probably something to do with unicode or charsets. I believe in totem though tyou can automatically load subtitles if they are in the root dir of the movie.

Goodluck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.