Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

[EDIT] Just in case this could help someone...

I have found a .... new solution?

http://www.nomachine.com/preview/download-package.php?Prod_Id=14

I am guessing that's nomachine's next version of their server/player. I tried the player preview with my my existing nomachine nx server setup, without upgrading the nx server. It seems to work. I am not sure if it is disabling the render extension, but at least there is no major slow down like before.

There are more artefacts on screen when switching window or drag-and-dropping, but they go away, so so far is pretty useful. [/EDIT]


[Edit] I later realized my issue only occurs when I am using NX to remote access my machine. Therefore I edited the title and description.

I have also found the temp solution, which is to "disable render extension" in the custom display settings. But doing so makes the NX experience very slow laggy, and not that nice to look at. [/EDIT]

I did a fresh install on a new computer, and was trying to setup my fonts.

When I log in remotely via NX, my the text are missing on all gtk based interfaces.

That means most menues (except for unity), right click menues, applications themselves, terminal, and so on.

About the only thing unaffected is firefox. all the texts are showing just fine for firefox. So that probably already says something about text permissions.

I went to check if my fonts have the correct permissions and they do.

I removed my custom settings from /etc/fonts/config.d, and still the texts are missing.

There is a work around by using "disable render extension" in the custom display settings.

How do I fix this issue permanently?

share|improve this question
    
ok, i've kept on testing. I noticed something. when I click on the Alt menu items (such as Edit), I can see E and t showing up. So the fonts are definitely there. It just for some reason they are usually blanked out by something. –  hansioux Oct 11 '12 at 4:59

1 Answer 1

up vote 2 down vote accepted

I have found solution for identical problem in Arch forums.

You need to downgrade libcairo2 to 1.10 version (I have downloaded it from precise-updates repo - http://packages.ubuntu.com/precise-updates) and make order in resulting dependency mess.

I had to downgrade as well following packages: libcairo2:i386 (my system is amd64, but e.g. acroread depends on the 32-bit version of the library), libpoppler-glib8, and poppler-utils. The last two downgrades demanded installation of libpoppler19. All the poppler packages was taken from precise repos: http://packages.ubuntu.com/precise

Of course it is not a permanent solution, but everything works fine. I'm afraid we need to wait for some patch for the cairo library.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.