Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I've been having multiple issues installing both 12.04 and natty narwhal 11.04.

I installed from a usb drive both times exactly as ubuntu.com said to onto a custom build desktop with a Atheros ar2143 pci wireless card. However, whenever i install or run from the usb there is no wifi connection and i can only connect through wired ethernet.

I had wireless for a very brief period of time while i finished installing 12.04 for the first time while i was right next to my router, but then it stopped working entirely. I moved the comp to my room and then no wireless connections showed up at all after that. Since then both 12.04 and 11.04 have only had an internet connection through a wire.

Also, more often than not, if i boot from my hdd and dont have the ethernet cable in the load up screen will freeze and begin flashing.

Ive made sure the card is properly seated, the led turns on indicating it has power. Also ifconfig shows that the card is being identified and rfkill list shows that nothing is being hard or soft blocked. Ive tried

share|improve this question
    
Bumping for answers or help –  user95625 Oct 11 '12 at 16:39
add comment

1 Answer

just install the wireless driver. to install it you have to connetc with wired connection and then go to "Additional Driver" let the Additional driver searching for your wifi driver then check the wifi driver and click activated. wait until your driver downloaded and installed.

share|improve this answer
    
the only driver that shows up is the one for my graphics card and that even fails when i tried installing it. –  user95625 Oct 11 '12 at 3:29
    
maybe you have problem with your internet connection. . . .check your wired internet connection –  Ujang Karnadi Oct 11 '12 at 3:34
    
The wireless works fine. I have a ps3, multiple laptops and a tablet all connected to wifi. This is the only thing thats blocked. It usually shows wifi networks when it boots properly but wont connect and just keeps asking for the password again. –  user95625 Oct 11 '12 at 3:41
    
so your wireless driver already installed? –  Ujang Karnadi Oct 11 '12 at 3:47
    
Well i meant the internet connection works fine, but im not sure if the driver is installed. It must be since it doesnt show up in the additional drivers. I've been having a lot of trouble installing other drivers though, both from the additional drivers and from using terminal to install them. –  user95625 Oct 11 '12 at 3:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.