Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 with ATI Radeon 6870 connected to my 40' Sharp TV.

The video image is slightly jigged, like breaking a bit and slightly delayed. It just isn't smooth. The computer is very fast, like i7 with 12gb ram. I tried to run the same video with my mac laptop and on the tv with the same connection cable and it was running smoothly.

i tried changing the video output in VLC to x11, increase caching, h264 skip loop filter to all, increase monitor refresh rate although it's already at 60 and it's an LCD tv.

this is my xorg.conf :

Section "ServerLayout"
        Identifier     "amdcccle Layout"
        Screen      0  "amdcccle-Screen[3]-0" 0 0
EndSection

Section "Module"
        Load  "glx"
EndSection

Section "Monitor"
        Identifier   "0-DFP9"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "TargetRefresh" "60"
        Option      "Position" "0 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
        Option      "PreferredMode" "1920x1080"
EndSection

Section "Monitor"
        Identifier   "0-DFP10"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1280x1024"
        Option      "TargetRefresh" "60"
        Option      "Position" "0 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Device"
        Identifier  "amdcccle-Device[3]-0"
        Driver      "fglrx"
        Option      "Monitor-DFP9" "0-DFP9"
        BusID       "PCI:3:0:0"
EndSection

Section "Screen"
        Identifier "Default Screen"
        DefaultDepth     24
EndSection

Section "Screen"
        Identifier "amdcccle-Screen[3]-0"
        Device     "amdcccle-Device[3]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
share|improve this question

1 Answer 1

Same problem with 8 core AMD with a 6970 running at 1375hertz

You can go into AMD config- usually under the settings menu and enable "Tear Free" under the "Display Options" -- you don't need to run the administrator version- ignore the notice.

You can create a launch for amd config by typing gksu amdcccle in the command box rather than using the goofy amd admin launch in the menu.

Even with tear free enabled you loose the tearing but have other problems. Anyway worth a try. Then you can turn off tearing and go down under 3D and make everything "performance" Still nothing works as well as it should. Very annoying.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.