Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 armhf to my beagleboard-xm and now trying to connect to a wireless network. First, I checked if I can search for available networks:

ubuntu@arm:~$ iwlist scan
lo        Interface doesn't support scanning.

usb0      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: EA:7D:EF:60:C9:0B
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=70/70  Signal level=-23 dBm
                    Encryption key:on
                    ESSID:"ghostrider"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Ad-Hoc
                    Extra:tsf=000000005a1ab50e
                    Extra: Last beacon: 6242ms ago
                    IE: Unknown: 000A67686F73747269646572
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030101
                    IE: Unknown: 06020000
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1A2C181BFF00000000000000000000000000000000000000000000
                    IE: Unknown: 3D16010800000000FF000000000000000000000000000000
                    IE: Unknown: DD09001018020000000000

Then I edited /etc/network/interfaces file to the following:

root@arm:/etc/wpa_supplicant# cat /etc/network/interfaces
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp
# Example to keep MAC address between reboots
#hwaddress ether DE:AD:BE:EF:CA:FE

# WiFi Example
auto wlan0
iface wlan0 inet dhcp
    wpa-ssid "ghostrider"
    wpa-psk "b34d373eb2fb836a43b0afffe783c7d0af694724506c9e77b06d1021302905bf"

But I cannot still connect to the wireless network:

root@arm:/etc/wpa_supplicant# iwconfig
lo        no wireless extensions.

usb0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Asociated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

eth0      no wireless extensions.

root@arm:/etc/network# ifup wlan0
Failed to bring up wlan0.

What is wrong? Should I change any other files also? But I think it was enough. By the way if you are curious about where that wpa-psk came from:

zero@ghostrider:~$ wpa_passphrase ghostrider 34bddf67c2
network={
    ssid="ghostrider"
    #psk="34bddf67c2"
    psk=b34d373eb2fb836a43b0afffe783c7d0af694724506c9e77b06d1021302905bf
}

I will appreciate any effort to help.

Regards, Amadeus

ps: Also I tried to connect manually:

root@arm:/etc/network# iwconfig wlan0 essid ghostrider key s:34bddf67c2

But this did not solve my problem also.

`root@arm:/home/ubuntu# ifup wlan0 Failed to bring up wlan0. root@arm:/home/ubuntu# tail -f /var/log/syslog Dec 31 18:05:13 arm dhclient: No DHCPOFFERS received. Dec 31 18:05:15 arm dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9 Dec 31 18:05:24 arm dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15 Dec 31 18:05:39 arm dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12 Dec 31 18:05:51 arm dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7 Dec 31 18:05:58 arm dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9 Dec 31 18:06:07 arm dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20 Dec 31 18:06:27 arm dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18 Dec 31 18:06:45 arm dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8 Dec 31 18:06:53 arm dhclient: No DHCPOFFERS received.

Properties of the network that I am trying to connect:

`enter image description here

enter image description here

share|improve this question
    
Have you tried service networking restart after editing /etc/network/interfaces? –  Evandro Silva Oct 10 '12 at 20:34
    
@EvandroSilva I did not, but I thought rebooting the device would do the same. Anyways, I tried it now and stuck at here about 10mins: * Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces * Reconfiguring network interfaces... –  Xentius Oct 10 '12 at 20:49
    
@EvandroSilva Allright, here is the output: Failed to bring up wlan0. –  Xentius Oct 10 '12 at 21:04
    
Try following @rosch instructions, I would answer something similar. –  Evandro Silva Oct 11 '12 at 0:55
    
Did you create your ghostrider wifi in ad-hoc mode on purpose? Is a dhcp server running? –  rosch Oct 11 '12 at 16:57
show 1 more comment

1 Answer

Since the wireless is using WEP encryption, first make sure to comment out all lines about wlan0 in /etc/network/interface.
Then do the following (replace "essid" and wepkey with your actual wireless name and key):

sudo ifconfig wlan0 down
sudo ifconfig wlan0 up  
sudo iwconfig wlan0 essid "essid"
sudo iwconfig wlan0 key wepkey

Check if everything looks fine with:

sudo iwconfig wlan0

Then start dhclient:

sudo dhclient wlan0

If still no success your card might not support adhoc. More information here.

other sources:

How do I connect my server to a WEP encrypted wireless network?

share|improve this answer
    
# ifdown wlan0 && ifup wlan0 ifdown: interface wlan0 not configured Failed to bring up wlan0. # /etc/init.d/networking restart Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces * Reconfiguring interfaces... Failed to bring up eth0. Failed to bring up wlan0. –  Xentius Oct 11 '12 at 14:46
    
Are you saying you followed all 3 steps first and this is what you're getting? If yes please try this: iwconfig wlan0 mode managed iwconfig wlan0 essid any then do the ifdown/ifup wlan0. –  rosch Oct 11 '12 at 16:29
    
@rosch yes I followed all 3 steps but got that error. Now I tried what you suggested and after ifup wlan0 step, I got the error: Failed to bring up wlan0. –  Amadeus Bachmann Oct 17 '12 at 17:37
    
look at the syslog to find clues: tail -f /var/log/syslog –  rosch Oct 17 '12 at 17:50
    
@rosch according to syslog, it seems like my problem is related dhcp server. I edited the question could you please check again? –  Amadeus Bachmann Oct 17 '12 at 18:04
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.