Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 alongside Windows 7 in a Vaio T13 ultrabook.

I cannot use the the Fn+F4 or Fn+F5 to change the brightness. The bubble appears indicating that brightness is being changed but with no visual impact on the screen.

I've tried many solutions involving the manipulation of the /etc/default/grub file but none of them worked. Whenever I tried this manipulation the screen still didn't change, however the bubble stopped functioning properly.

This is not a problem of the Fn shortcut. Even when I try to change it in the Brightness and Lock on System Settings, the bar does scroll but the screen remains unchanged.

Does any one has a way around this mystery?

share|improve this question

5 Answers 5

This answer worked for me.

Open a terminal

Type sudo su root and press Enter

Type echo 400 > /sys/class/backlight/intel_backlight/brightness. Use the brightness level you wish.

Type exit

Close terminal

share|improve this answer
    
This doesn't really solve the problem but it helps for the time being ... I still need to do this everytime I boot ... –  Alex Barreira Oct 11 '12 at 19:15
    
I agree with you that it's not the ideal solution but at least it permits me to reduce battery consumption. If you want you can write a bash script with these commands and set it to run after boot. –  To Do Oct 12 '12 at 7:01
    
echo 400 | sudo tee /sys/class/backlight/intel_backlight/brightness > /dev/null and you don't have to mess with su nonsense, it can also be used in scripts. –  ActionParsnip Nov 2 '12 at 13:06
    
Thanks ActionParsnip –  To Do Nov 3 '12 at 18:39

LCD Brightness Control

This is fixable by editing one's xorg.conf file. Open a terminal window and type the following:

sudo nano /etc/X11/xorg.conf

This will open your X server configuration (after prompting for your password). You should see a section titled "Device" that looks as follows:

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"
EndSection

Append a line so it appears like this:

Section "Device"
        Identifier      "Default Device"
        Driver  "nvidia"
        Option  "NoLogo"        "True"
        Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection

You will need to restart your graphical server (or reboot) for this change to take effect.

share|improve this answer
    
On Ubuntu 13.04, /etc/X11/xorg.conf does not exist. –  kostmo Sep 10 '13 at 4:58

You may have a look at this thread:

http://ubuntuforums.org/showthread.php?t=2033273&page=2 (message 11, 12 and following).

Adding the scripts described in the above thread:

/etc/acpi/brightdown.sh

/etc/acpi/brightup.sh

/etc/acpi/events/sony-brightness-up

/etc/acpi/events/sony-brightness-do`wn

solves the problem and enables the Fn+F4 or Fn+F5 keys.

share|improve this answer

Install xbacklight (sudo apt-get install xbacklight) and try this command to reduce the brightness by 20%: xbacklight -20. If it works, then try this script (remember that you have to install inotify-tools and configure some of the paths inside the script -- there are comments inside for help):

How to use xbacklight with brightness keys in a VAIO

It worked on my VPC.

share|improve this answer

More than 2 years back i had similar problem with my dell inspiron laptop.At that time

This work by kamal mostafa solved my problem and this patch has been already applied to 3.1 kernels

Now i have upgraded to sony vaio ultrabook and i have similar problem.After some research and hacking i am able to solve brightness control to normal.

  1. First i found acer_wmi and sony_laptop kernel modules are loading while startup using lsmod command.
  2. Second i found was two backlight on /sys/class/backlight acpi_video and intel_backlight . *here brightness keys working smoothly with /sys/class/backlight/acpi_video/brightness but changes are not reflected on screen* *second screen brightness changes do get reflected with intel_backlight * echo 400 > /sys/class/backlight/intel_backlight/brightness
  3. acer_wmi and sony_laptop both modules checks if acpi_video is compatible and loads the module. *here i blacklisted acer_wmi and added kernel boot parameter to disable acpi_video and sony backlight which gets loaded by sony_laptop module while it detects acpi_video is incompatible*

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor sony_laptop.backlight=0"

Now there will be only one intel_backlight in /sys/class/backlight folder which easily gets bind with gnome-powe-manager functioning brightness control keys.i am sure at this point it will also work kde's power-management tool

During boot you will find message but it works fine:

[ 9.999247] sony_laptop: 0' invalid for parameterbacklight'

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.