Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to setup wakeonlan on my desktop which uses an Asus M3N72-D and is running Kubuntu 12.04 64bit. I believe I have setup the bios correctly. I have enabled PME. I didn't find any other setting that mentioned wake on lan except EuP which I have disabled (it turns off WOL in the S5 state). In my rc.config put:

sudo ethtool -s eth0 wol g

But that hasn't resolved the problem. Some things that might hint at a solution are that presently if I go into standby the computer will not come out of standby, and when I shutdown the computer the lights next the ethernet port always turn off.

I also ran wireshark while the computer was running and saw that the magic packet is able to reach the desktop with the correct MAC address.

Here is the results for ethtool eth0

    Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
                            1000baseT/Half 1000baseT/Full 
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                         100baseT/Half 100baseT/Full 
                                         1000baseT/Full 
    Link partner advertised pause frame use: Symmetric
    Link partner advertised auto-negotiation: Yes
    Speed: 1000Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
                           drv probe ifdown ifup
    Link detected: yes

Is there anything else I can try to fix the problem?

share|improve this question

1 Answer 1

The ethernet LED lights should not turn off completely after the shutdown. If they are then your network card is turned off and you will not be able to wake the machine.

Make sure you paste this line before the exit 0 command of /etc/rc.local (and after the #!.. line):

ethtool -s eth0 wol g

Then wake it up with:

wakeonlan 00:11:22:33:44:55

Some cards need the following:

sudo sh -c "echo enabled > /sys/class/net/eth0/device/power/wakeup"

source: https://wiki.archlinux.org/index.php/Wake-on-LAN

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.