Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My friend and me are connected via LAN router, and we both have Ubuntu 12.04. There is a problem with network. My friend can see my computer on network, but I can't see his computer. I can ping him and connect to phpmyadmin (he has PHP server installed) but I can't access files on his computer? What seem to be a problem?

share|improve this question
Have you installed the samba package on both computers? Then reboot both computers and try again. – medigeek Oct 10 '12 at 19:01
We did that and nothing has changed. – Sasha Oct 10 '12 at 19:02
install package nbtscan and execute this command (it will try and discover connected computers): nbtscan $(hostname -I | cut -d ' ' -f 1)/24 – medigeek Oct 10 '12 at 19:38
Ok, I did that and it is working (program had found my friends computer ), but when I go to browse network I still can't see my friends computer. – Sasha Oct 10 '12 at 19:44
up vote 2 down vote accepted

According to the comments above I would:

  1. check if there's a firewall of some sort that blocks connection to specific ports (if the user remembers setting up some blocking application, if it's a default install then the firewall is off by default)

  2. boot from a live cd/usb and see if the problem persists.

  3. try this: install the ssh package on both PCs, reboot, and try to connect through ssh:

    ssh remote-user@IP

(where you substitute remote-user with the username on the other computer and the IP address)

If this works, it should ask you for a password and allow you to login.

After installing ssh, you can probably use SFTP to access files on the remote system. Open nautilus, press CTRL+L, it will show the "location bar", where you type:


It should ask you for a password.

share|improve this answer
This is working. Thank you for helping me :) – Sasha Oct 11 '12 at 8:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.